HKS EVC-S not contorling my boost !!! - EvoXForums.com - Mitsubishi Lancer Evolution X Forums
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X Performance
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

Evo X Performance General discussion for performance topics that are unique to the Evo X. IF THE TOPIC IS COMMON WITH OTHER LANCERS, PLEASE POST IT IN: '08+ Lancer Common.
Sponsored by:

Reply
 
Thread Tools Display Modes
Old 09-24-2009, 04:45 AM   #1
grafix143
Just Spooling Up
 
Join Date: Jun 2009
iTrader: (0)
Posts: 397
HKS EVC-S not contorling my boost !!!

Hi ,
Lately i installed HKS EVC-S boost controller , but i think i have done some mistake some where cause even if i set the target boost to 10psi @ wot it jump to 24 psi !!??

I didnt disconnect the original Wastegate Solenoids i conneted it to the HKS solenoids hose using T-join !!??

and also i had remove the boost control pill b4 , shall i put it back ?

any ideas
grafix143 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-24-2009, 05:15 AM   #2
evodicted
Just Spooling Up
 
Join Date: Sep 2008
iTrader: (0)
Location: South pacific
Posts: 139
I got a blitz boost controller...I completely unplugged the stock solenoids so Turbo -->New boost controller --> Wastegate.
It's working fine for me.


Good luck :-)
__________________
BakaUnchi Tuned
http://www.facebook.com/JonJeebusTuning
evodicted is offline   Reply With Quote Quick reply to this message
Old 09-24-2009, 07:38 AM   #3
grafix143
Just Spooling Up
 
Join Date: Jun 2009
iTrader: (0)
Posts: 397
aha , so i have to cancel the t-join ,
i was worry about how will the ECU read the boost thats all
i shall do the changes 2night
grafix143 is offline   Reply With Quote Quick reply to this message
Old 09-24-2009, 11:26 AM   #4
on2it
[X Performance Mod]
[Oceania Mod]
[Automotive News]
 
on2it's Avatar
 
Join Date: Dec 2007
iTrader: (100)
Location: Auckland, New Zealand
Posts: 10,004
let us know how you get on ^
__________________
http://www.evoxforums.com/forums/signaturepics/sigpic324_1.gif
Current|HKS UICP|HKS Filter|HKS racing suction pipe kit|Modified Stock Exhaust|EcuTek FQ360 tune|ETS 3.5FMIC|Swift Springs|ACT ME-HDSS|ACT Streetlite Flywheel|
Installing
|FIC 1100cc injectors|K27 Surgetank kit+ Bosch044|
To Come
|BB FPGreen|Kelford Cams|Perrin3port|Perrin Bov|Tomei FPRegulator |Tomei FP guage|
on2it is offline   Reply With Quote Quick reply to this message
Old 09-24-2009, 11:34 AM   #5
grafix143
Just Spooling Up
 
Join Date: Jun 2009
iTrader: (0)
Posts: 397
Quote:
Originally Posted by on2it View Post
let us know how you get on ^
sure later
__________________
2.0L built motor, MAP T3 Turbo Kit PTE 5862 BB
grafix143 is offline   Reply With Quote Quick reply to this message
Old 09-24-2009, 03:42 PM   #6
grafix143
Just Spooling Up
 
Join Date: Jun 2009
iTrader: (0)
Posts: 397
ok problem solved , i canceled the t-join which means canceled the stock solenoids and direct the HKS solenoids to the turbo air hose
__________________
2.0L built motor, MAP T3 Turbo Kit PTE 5862 BB
grafix143 is offline   Reply With Quote Quick reply to this message
Old 09-24-2009, 08:23 PM   #7
babypanda
Member
 
Join Date: Sep 2009
iTrader: (0)
Posts: 50
Quote:
Originally Posted by grafix143 View Post
ok problem solved , i canceled the t-join which means canceled the stock solenoids and direct the HKS solenoids to the turbo air hose
yeah i had that same problem in past, except it ended in epic failure for me, boost spike to 36psi and BOOOOOOOOOOOOOOOOOOM lol
babypanda is offline   Reply With Quote Quick reply to this message
Old 09-25-2009, 09:03 AM   #8
grafix143
Just Spooling Up
 
Join Date: Jun 2009
iTrader: (0)
Posts: 397
Quote:
Originally Posted by babypanda View Post
yeah i had that same problem in past, except it ended in epic failure for me, boost spike to 36psi and BOOOOOOOOOOOOOOOOOOM lol
am sorry for u , when i had the problem i had a boost gauge installed as well long time ago , so i saw that stock boost was 20psi , after i installed the HKS and my boost went to 25 psi but i set it to 10psi but still
so i have up flooring for the next day , i drive just normal my boost were like 0 or some until i fixed it last night
now am flooring again @ 10 psi loool
__________________
2.0L built motor, MAP T3 Turbo Kit PTE 5862 BB
grafix143 is offline   Reply With Quote Quick reply to this message
Old 09-25-2009, 11:46 AM   #9
on2it
[X Performance Mod]
[Oceania Mod]
[Automotive News]
 
on2it's Avatar
 
Join Date: Dec 2007
iTrader: (100)
Location: Auckland, New Zealand
Posts: 10,004
Quote:
Originally Posted by grafix143 View Post
ok problem solved , i canceled the t-join which means canceled the stock solenoids and direct the HKS solenoids to the turbo air hose
congrats mate.. feels great catching and sorting out a problem like that eh?
__________________
http://www.evoxforums.com/forums/signaturepics/sigpic324_1.gif
Current|HKS UICP|HKS Filter|HKS racing suction pipe kit|Modified Stock Exhaust|EcuTek FQ360 tune|ETS 3.5FMIC|Swift Springs|ACT ME-HDSS|ACT Streetlite Flywheel|
Installing
|FIC 1100cc injectors|K27 Surgetank kit+ Bosch044|
To Come
|BB FPGreen|Kelford Cams|Perrin3port|Perrin Bov|Tomei FPRegulator |Tomei FP guage|
on2it is offline   Reply With Quote Quick reply to this message
Old 09-26-2009, 08:23 PM   #10
grafix143
Just Spooling Up
 
Join Date: Jun 2009
iTrader: (0)
Posts: 397
Quote:
Originally Posted by on2it View Post
congrats mate.. feels great catching and sorting out a problem like that eh?
yeah man , it was fun , as am new into turbo world
as all my cars are N/A

i set the boost to 20psi

i can say wow i liked it , its has better response and it hold the boost without tearing down
__________________
2.0L built motor, MAP T3 Turbo Kit PTE 5862 BB
grafix143 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
TurboXS DTEC, HKS, AEM, Perrin and HOA boost controllers! Control your BOOST!!! OAKOS Automotive Merchant Marketplace 150 10-01-2013 08:43 PM
I install AEM tru boost only for read boost but read 10psi what is wrong ? yucel Evo X Turbo 4 09-12-2009 06:03 AM
Going back from Tru Boost controller to computer controlled boost Government Issue Evo X Turbo 2 08-26-2009 10:21 PM
Anyone install the AEM Tru-Boost Controller/Boost Gauge EvolvedX Evo X Turbo 1 06-02-2009 02:08 PM


All times are GMT. The time now is 02:54 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.