transmission service light - EvoXForums.com - Mitsubishi Lancer Evolution X Forums
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X Transmission & S-AWC System
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

Evo X Transmission & S-AWC System Discussion for transmission, axle, driveshaft, and related systems that are unique to the Evo X. IF THE TOPIC IS COMMON WITH OTHER LANCERS, PLEASE POST IT IN: '08+ Lancer Common.

Reply
 
Thread Tools Display Modes
Old 05-16-2011, 03:05 AM   #1
achinaghost52
Just Spooling Up
 
achinaghost52's Avatar
 
Join Date: Sep 2010
iTrader: (100)
Location: rolla, mo and kck
Posts: 457
transmission service light

there is a transmission service light that comes on everytime i drive the car. When this happens i lose my three different diff modes.
the problem occurred after i did a clutch swap on my own. I mistakenly put the wrong fluid into the center diff. a used the gear oil instead of atf. i quickly realized my mistake and drained the center and rear diffs and put in the correct fluid.
the light comes on after i drive my car for a hundred yards or so. sometimes i can get a 1/4 mile, sometimes not even out of my driveway. also, if i start the car up and let it warm up, then rev the engine some (as in showing my friends a new mod or something) the lights pop on. it goes away if i restart the car. but comes back when i start driving again.

I am planning on draining the diffs again because there might be some residual gear oil. i thought it could be a wheel speed sensor for a while, but the abs light would also come on. so i know it is just transmission related. any help you guys can offer is great. i am over 36k so the dealer wants to charge me to look at the car
__________________
2008 PB GSR 69k Miles VIN: 666
Tune in progress by Chet Rickerman, 335 whp/wtq
K&N Typhoon Kit+ Full Megan Turboback
Thermal Intake Manifold and Throttle Body Spacers
Depo 3.5" Intercooler + Hard Pipes
Magnus CMC + Braided Clutch Line
Competition Clutch Stg 4 + 9lb Fidanza Flywheel
BC BR Coilovers
AMS SS Brake Lines and Hawk HP+ Pads
18x9.5 +25 Rota Torques, Bronze
55w HID's +Custom 6000 lumen LED Light Rack
(30,000 Lumens total)
achinaghost52 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-16-2011, 03:07 AM   #2
Dblade
Just Spooling Up
 
Join Date: Mar 2010
iTrader: (0)
Location: Aiea, HI
Posts: 280
You should try pulling the codes.
__________________
Installed
Rexspeed CF hood dampers, Rally Armor Red logo, TWM short shifter / bushings, 35% tint, Agency Power Ti Tip CBE, Cobbs AP Stage 1 91 1.06

Ordered
Blue Relay package
Dblade is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 03:55 AM   #3
irmerm
Forum Lackey
 
Join Date: May 2009
iTrader: (0)
Location: Round Rock, TX
Posts: 3,475
did you leave off a wheel speed sensor?
__________________
2008 Evolution GSR Phantom Black
-----------------------
Mods:
K&N Drop-In Filter
CBRDSpeedFactory UICP
Eibach Pro-Kit Springs
irmerm is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 04:09 AM   #4
achinaghost52
Just Spooling Up
 
achinaghost52's Avatar
 
Join Date: Sep 2010
iTrader: (100)
Location: rolla, mo and kck
Posts: 457
ive tried pulling the codes with a scanner from autozone/o'reillys. there arent any. if it was a wheel speed sensor the abs wouldnt work and its warning light would be on too right?
__________________
2008 PB GSR 69k Miles VIN: 666
Tune in progress by Chet Rickerman, 335 whp/wtq
K&N Typhoon Kit+ Full Megan Turboback
Thermal Intake Manifold and Throttle Body Spacers
Depo 3.5" Intercooler + Hard Pipes
Magnus CMC + Braided Clutch Line
Competition Clutch Stg 4 + 9lb Fidanza Flywheel
BC BR Coilovers
AMS SS Brake Lines and Hawk HP+ Pads
18x9.5 +25 Rota Torques, Bronze
55w HID's +Custom 6000 lumen LED Light Rack
(30,000 Lumens total)
achinaghost52 is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 04:14 AM   #5
razorlab
aka bryan@GST
 
Join Date: Feb 2009
iTrader: (0)
Location: Bay Area, CA
Posts: 3,837
You don't put ATF in the front (transfer case) and rear diffs. You put gear oil in. Diaqueen LSD Fluid - 3775610

For the ACD and AYC pumps you use Diamond ATF SP III - ACH1ZC1X05

I'm surprised you haven't ruined the diffs yet.

Here is a handy list you can reference:

5 SPEED
- Gear Oil API classification GL-4 SEA 75W-85 or 75W-90
- Diaqueen M/T Fluid - MZ313376 (1gal)

Transfer Case
- Mitsubishi Limited Slip Differential Oil (LSD) or equivalent
- Diaqueen LSD Fluid - 3775610 (1 gal)

ACD Operating Fluid
- Diamond ATF SP III - ACH1ZC1X05 (1 qt)

Rear Differential
- Mitsubishi Limited Slip Differential Oil (LSD) or equivalent
- Diaqueen LSD Fluid - 3775610 (1 gal)

Mitsubishi Coolant
- MZ311986 (1 gal)

Mitsubishi Brake Fluid
- DOT 3
- MZ311987 (354 ml)

Mitsubishi Power Steering Fluid
- ACH1ZC1X04 (12 oz)


__________________
Bryan
2014 Evo GSR - E85 powered
2014 Ford Fiesta ST - It's a party!

The original E85 Army

Last edited by razorlab; 05-16-2011 at 04:19 AM.
razorlab is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 04:22 AM   #6
achinaghost52
Just Spooling Up
 
achinaghost52's Avatar
 
Join Date: Sep 2010
iTrader: (100)
Location: rolla, mo and kck
Posts: 457
thanks. i realized that i wasnt supposed to put gear oil in. i drained the center diff and rear diff's atf circuits and refilled with the proper fluid. i still have the problem and that is why i am posting it up. restating that i did something wrong and possibly hurt/ruined the diffs is not actually helping with anything. the diff obviously isnt ruined because i have driven the car almost 5k miles since and have confirmed that all four wheels spin
__________________
2008 PB GSR 69k Miles VIN: 666
Tune in progress by Chet Rickerman, 335 whp/wtq
K&N Typhoon Kit+ Full Megan Turboback
Thermal Intake Manifold and Throttle Body Spacers
Depo 3.5" Intercooler + Hard Pipes
Magnus CMC + Braided Clutch Line
Competition Clutch Stg 4 + 9lb Fidanza Flywheel
BC BR Coilovers
AMS SS Brake Lines and Hawk HP+ Pads
18x9.5 +25 Rota Torques, Bronze
55w HID's +Custom 6000 lumen LED Light Rack
(30,000 Lumens total)
achinaghost52 is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 04:22 AM   #7
achinaghost52
Just Spooling Up
 
achinaghost52's Avatar
 
Join Date: Sep 2010
iTrader: (100)
Location: rolla, mo and kck
Posts: 457
thanks for the list though
__________________
2008 PB GSR 69k Miles VIN: 666
Tune in progress by Chet Rickerman, 335 whp/wtq
K&N Typhoon Kit+ Full Megan Turboback
Thermal Intake Manifold and Throttle Body Spacers
Depo 3.5" Intercooler + Hard Pipes
Magnus CMC + Braided Clutch Line
Competition Clutch Stg 4 + 9lb Fidanza Flywheel
BC BR Coilovers
AMS SS Brake Lines and Hawk HP+ Pads
18x9.5 +25 Rota Torques, Bronze
55w HID's +Custom 6000 lumen LED Light Rack
(30,000 Lumens total)
achinaghost52 is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 04:26 AM   #8
razorlab
aka bryan@GST
 
Join Date: Feb 2009
iTrader: (0)
Location: Bay Area, CA
Posts: 3,837
Quote:
Originally Posted by achinaghost52 View Post
thanks. i realized that i wasnt supposed to put gear oil in. i drained the center diff and rear diff's atf circuits and refilled with the proper fluid. i still have the problem and that is why i am posting it up.
If you put ATF in the rear diff and front diff, you used the wrong fluid.

Are you talking about the actual diffs or the plastic reservoirs for the ACD and AYC? If you are talking about those, you actually need to bleed those systems as well.

Quote:
Originally Posted by achinaghost52 View Post
restating that i did something wrong and possibly hurt/ruined the diffs is not actually helping with anything. the diff obviously isnt ruined because i have driven the car almost 5k miles since and have confirmed that all four wheels spin
Ok, have fun figuring it out.
__________________
Bryan
2014 Evo GSR - E85 powered
2014 Ford Fiesta ST - It's a party!

The original E85 Army
razorlab is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 12:07 PM   #9
dboz
Forum Lackey
 
Join Date: Jun 2010
iTrader: (100)
Posts: 3,854
Sometimes with DIY jobs, it ends up costing you more than you saved DIY due to lack of knowledge/mistakes. Hope it works out. Just saying, it's too late now though. Always double/triple check everything before proceeding.

Just because the wheels are moving does not mean damage was not done or is still being done.

Time to shoot an email to SHEP or someone in the know as to what damage you may have done.
__________________

dboz is offline   Reply With Quote Quick reply to this message
Old 05-16-2011, 03:17 PM   #10
Yxd68
Forum Addict
 
Yxd68's Avatar
 
Join Date: Sep 2008
iTrader: (100)
Location: Vegas, Baby!
Posts: 6,590
As stated above, verify all the wheel sensors are connected and working.

1/4 mile is too short a distance to have any effect form the wrong fluids.
Yxd68 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
service engine soon light ! fibr Evo X General 9 03-08-2011 02:59 PM
service light?? maverick_124 Evo X General 5 03-20-2010 08:48 AM
Service engine Soon Light and TP Eyler_Evo_X Evo X Performance 13 12-18-2009 02:05 AM
service soon light evil35r Evo X Transmission & S-AWC System 2 09-11-2009 11:27 PM
Service Engine Soon Light On... EvolvedX Evo X Engine (4B11T) 10 06-02-2009 01:40 PM


All times are GMT. The time now is 07:55 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.