dreaded p0340 cam sensor code, and an interesting observation - EvoXForums.com - Mitsubishi Lancer Evolution X Forums
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X Engine (4B11T)
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

Evo X Engine (4B11T) Discussion for engine systems that are unique to the Evo X. IF THE TOPIC IS COMMON WITH OTHER LANCERS, PLEASE POST IT IN: '08+ Lancer Common.

Reply
 
Thread Tools Display Modes
Old 11-04-2011, 10:59 PM   #1
Beeble
Forum Lackey
 
Beeble's Avatar
 
Join Date: Jan 2010
iTrader: (0)
Location: Melbourne, Australia
Posts: 2,255
dreaded p0340 cam sensor code, and an interesting observation

a new 2.2 with GSC S2 cams, and we have the exact same issue LVS had.
P0340
we replaced both cam sensors, no dice.
reset the ecu. no dice.
checked voltage across both sensors...perfect.


now here's something interesting.
the spirals, or lobes, on the cams themselves that trigger the sensor :


if you look at the far end of the cams. the "cutout" there.
We compared a few different cams.
on the OEM cams, they both face the same way.
On the Tomei cams, they face towards each other (like the kelfords do in this pic)
On the GSC cams, they face away from each other.

any engineering types wish to comment on this? Would this affect the way the sensor functions.
Coz we are baffled why this code is coming up, and we know the sensors are good as they were in a running motor just a week ago. plus we tried two brand new ones!.




^ here is the pic from the GSC website. sorry it's so small.
notice the cutouts face TOWARD each other in this pic. Just like the kelfords and Tomei ones.
in our cams - they face the opposite direction, outwards.
(and yes, we checked, we definitely have them in the right spots )
__________________
X MR - MAP 2.2/GSC S2/mongrel GTX3576/FIC1100/Plazmaman cooler/UR catback/Arogosta coilies/Whiteline sway
Tuning help for your Evo or RA? PM me!


Last edited by Beeble; 11-04-2011 at 11:07 PM.
Beeble is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-04-2011, 11:09 PM   #2
Beeble
Forum Lackey
 
Beeble's Avatar
 
Join Date: Jan 2010
iTrader: (0)
Location: Melbourne, Australia
Posts: 2,255
PS i would really appreciate it if someone with these GSC cams working properly, had a chance to pop off their valve cover and take a look at the orientation for me!!

What i am wondering is - is this a manufacturing issue?
__________________
X MR - MAP 2.2/GSC S2/mongrel GTX3576/FIC1100/Plazmaman cooler/UR catback/Arogosta coilies/Whiteline sway
Tuning help for your Evo or RA? PM me!

Beeble is offline   Reply With Quote Quick reply to this message
Old 11-04-2011, 11:21 PM   #3
droppinbottom
X-phile
 
droppinbottom's Avatar
 
Join Date: May 2009
iTrader: (100)
Location: Wa. State
Posts: 747
3dman1 is running these cams and from what I am aware of he has not had any issues. Might give him a pm.
__________________
AMREngineering Coilovers
droppinbottom is offline   Reply With Quote Quick reply to this message
Old 11-04-2011, 11:25 PM   #4
Beeble
Forum Lackey
 
Beeble's Avatar
 
Join Date: Jan 2010
iTrader: (0)
Location: Melbourne, Australia
Posts: 2,255
^ yeah i am sure there are 100+ sets running around in 4Bs by now.
Just struck us as odd.... exact same error LVS had. and pretty much identical builds.
I'll PM him. wonder if he's happy to pop the lid on his motor
__________________
X MR - MAP 2.2/GSC S2/mongrel GTX3576/FIC1100/Plazmaman cooler/UR catback/Arogosta coilies/Whiteline sway
Tuning help for your Evo or RA? PM me!

Beeble is offline   Reply With Quote Quick reply to this message
Old 11-04-2011, 11:48 PM   #5
droppinbottom
X-phile
 
droppinbottom's Avatar
 
Join Date: May 2009
iTrader: (100)
Location: Wa. State
Posts: 747
English Racing may have pictures of them installed in his motor as they did the original documentation of the tear down of the lemmon engine that the ERL was putting out.
__________________
AMREngineering Coilovers
droppinbottom is offline   Reply With Quote Quick reply to this message
Old 11-05-2011, 01:07 AM   #6
LVSBB6
Forum Lackey
 
LVSBB6's Avatar
 
Join Date: Oct 2008
iTrader: (100)
Posts: 3,485
Thanks for posting this up Beeble, now I know I'm not the only one having this issue...Are you running the AMS 2.2L as well? I hope someone will have a solution for us soon.

On the side note my car is still down due to the fact we can't still get it to crank...all we did was unplugged the ECU and lost cranking....
__________________
Advan RZ
Alcon BBK
AMS 2.2L long block/750R/AFPR
ARC OC/titan exhaust/r-cap/knob
Billion r-hoses
Blitz S-tank/TC/RS coolers/radiator
CARBING arm bar
Chargespeed f & h-vents
Coltspeed GT shifter/cm-support/ign
Cosworth IC
CRAFT SQUARE TCA-RF
Deck Mechanical trunk lip
ESPRIT GT 052
GSC S2
ID 1000
JUN kit/TB/oil thermo + pan
Kansai s-bars/grill/underbrace
Ohlins DFV
Okada coils + lift
Project Kics R40
Ralliart ac & shift panel/pedals/oil cap
Volk Racing CE28N Genesis
YR Advance shifters

Last edited by LVSBB6; 11-05-2011 at 02:01 AM.
LVSBB6 is offline   Reply With Quote Quick reply to this message
Old 11-05-2011, 01:27 AM   #7
LVSBB6
Forum Lackey
 
LVSBB6's Avatar
 
Join Date: Oct 2008
iTrader: (100)
Posts: 3,485
Here are some pics when the lid was off:







Does it look similar to yours?
__________________
Advan RZ
Alcon BBK
AMS 2.2L long block/750R/AFPR
ARC OC/titan exhaust/r-cap/knob
Billion r-hoses
Blitz S-tank/TC/RS coolers/radiator
CARBING arm bar
Chargespeed f & h-vents
Coltspeed GT shifter/cm-support/ign
Cosworth IC
CRAFT SQUARE TCA-RF
Deck Mechanical trunk lip
ESPRIT GT 052
GSC S2
ID 1000
JUN kit/TB/oil thermo + pan
Kansai s-bars/grill/underbrace
Ohlins DFV
Okada coils + lift
Project Kics R40
Ralliart ac & shift panel/pedals/oil cap
Volk Racing CE28N Genesis
YR Advance shifters
LVSBB6 is offline   Reply With Quote Quick reply to this message
Old 11-05-2011, 02:19 AM   #8
Beeble
Forum Lackey
 
Beeble's Avatar
 
Join Date: Jan 2010
iTrader: (0)
Location: Melbourne, Australia
Posts: 2,255
^^ interesting.... thanks for the pics.
LVS your cams are "faced inward" , just like in the manufacturer photos i posted.
ours face the opposite direction.

our 2.2 was not made by AMS but at the end of the day it shouldn't matter who built it. it either has to do with cams themselves or electronics AFAICT.

I'm becoming increasingly concerned that the wrong billets may have been used...
I'll contact GSC and see what they have to say about it.



it makes sense to me that they should both be facing the same way - as the OEM cams are - both cams rotate the same direction after all...
__________________
X MR - MAP 2.2/GSC S2/mongrel GTX3576/FIC1100/Plazmaman cooler/UR catback/Arogosta coilies/Whiteline sway
Tuning help for your Evo or RA? PM me!

Beeble is offline   Reply With Quote Quick reply to this message
Old 11-05-2011, 03:04 AM   #9
Tephra
[Gearhead]
 
Join Date: Nov 2009
iTrader: (0)
Location: Melbourne, Australia
Posts: 2,646
looks like they are out of phase to me...

Ads are YOUR cams the same as Daz's?
__________________
AUDM Black Evo IX 07 spec - writeoff thanks to someone that doesn't understand what a STOP sign is!
AUDM Yellow Evo IX - writeoff thanks to me rolling it at the Phillip Island Grand Prix Circuit
AUDM White Evo X - Powered by Colby@Tactrix, Richard@Aquamist, Chris@MAP (2.5L )

RIP Michael Lomker
Tephra is offline   Reply With Quote Quick reply to this message
Old 11-05-2011, 03:12 AM   #10
Beeble
Forum Lackey
 
Beeble's Avatar
 
Join Date: Jan 2010
iTrader: (0)
Location: Melbourne, Australia
Posts: 2,255
D , i can only comment on mine as the lid isn't on the motor yet.
Darrin's got the valve cover on. but i think Monday it will have to come off. I'm just assuming they are the same as both motors were built together.

i double checked mine - IN and EX are definitely in the right place. marks all line up on the head. but the cutouts both face outward and the OEM setup has one facing in and one facing out (ie both the same direction)

There's another head there with the Tomeis in it. the both face inward. and that motor ran fine...

so - possibly 180* out of phase? it's a remote possibility. the boys will have to triple check everything next week.

PS i thought it was only the INlet cam sensor that was detecting TDC for cranking? and i assume IN and Ex sensors are used in running to determine MivecActual?
does that sound fair?
as the code comes up in cranking, and it won't fire, i was guessing the inlet sensor was somehow the issue...
__________________
X MR - MAP 2.2/GSC S2/mongrel GTX3576/FIC1100/Plazmaman cooler/UR catback/Arogosta coilies/Whiteline sway
Tuning help for your Evo or RA? PM me!

Beeble is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cam install- P0017 code inslowoutfast Evo X Turbo 1 02-18-2011 05:35 AM
#1 O2 Sensor Code Doubleup Evo X General 2 01-21-2011 02:42 PM
Cam sensor Code??? pcasso87 Evo X Engine (4B11T) 5 01-27-2010 06:43 AM
Interesting Page on Cam's flagg77 Evo X Tuning 2 05-08-2009 11:01 PM
Interesting observation on my Fast Key... antics22 '08+ Lancer Common Electronics & Audio 27 04-06-2008 04:03 PM


All times are GMT. The time now is 06:13 AM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.