EvoXForums.com - Mitsubishi Lancer Evolution X Forums - Reply to Topic
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > '08+ Lancer Common > '08+ Lancer Wheels, Suspension, & Brakes > 1G DSM Motor Mounts on my 08 Lancer GTS
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

'08+ Lancer Wheels, Suspension, & Brakes Discussion for wheels, tires, brakes, and suspension related topics that are common among all 08+ Lancers.

Thread: 1G DSM Motor Mounts on my 08 Lancer GTS Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Security Question
While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what the 2x4 is made of.
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
03-07-2016 05:24 PM
Isaque
1G DSM Motor Mounts on my 08 Lancer GTS

Hey Guys,
I'm posting this on here as I thought some of you might be interested in doing this mod! I had originally posted in on 9Glancers a while ago.
It's going on almost 2 years and no issues at all with the car. Other than it vibrates to hell... But I like it.
Feel free to ask questions if something isn't clear.
I will try to give details as best as possible.

Parts needed:
Set of 1990-1994 prothane motor mounts from Eagle Talon/Eclipse
My friend Abbas @ RTM Racing can take care of you on that.
https://www.rtmracing.com/xcart/prod...at=1848&page=1

Custom washers for Passanger side: 3 pieces
Diameter of 1.25" with hole diameter of 0.400" for the bolt X 0.250" thick. You'll need to raise the bracket about 1/4" because the new motor mount hold is in the middle of the mount. Original one on the car is offset from the center.
If you can't get these spacers made, then just use washers with those specs and that way will work too. It's how mine are right now while my supplier is making the spacers for me.
I also took the 2 rubber slices that are on the ends of the mount and buffed them down to about 0.180" so that they would fit on the ends of the mount as there was some gap to fill.
I hope this shows more or less what I mean


Drivers side mount:
This mount that is purchased is 3.5" in diameter and needs to be machined down to 3.150" - 3.200" This way the rubber mount will fit the existing bracket. You can get this done with a lathe, for you local guys, I can help out if you don't have a source.
Another good idea is to machine/grind down the ears that are on the bottom two holes of the bracket. This will make your life much simpler when reinstalling the bracket. I had a tough time removing the bracket due to these ears. There isn't room to use a wratchet becasue of the tranny being there. Best bet is to use a wratchet wrench.
Here is what the mount looks like with the ears grinded off.


There is also an offset on the drivers side but I only used a spacer washer of about 0.100" to bring up the drivers side a bit. These mounts are heavy duty and comparing to the stock ones, I don't see the engine sagging with these mounts so the home position should be pretty close.

Here is a picture from the back of the engine bay facing the front of the drivers side mount.


I hope this is a clear enough picture and this isn't for everyone. Even my bumper vibrates and people ask me if my car needs repair. I had a guy tell me sounded like one of my cylinders weren't working! Put his hand on the hood and felt the vibration. LOL..
Cheers

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 12:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.