EvoXForums.com - Mitsubishi Lancer Evolution X Forums - Reply to Topic
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X General > *OFFICIAL* Accident/Crash Help Thread
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

Evo X General General discussion on the 2008+ Mitsubishi Lancer Evolution X

Thread: *OFFICIAL* Accident/Crash Help Thread Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Security Question
While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what the 2x4 is made of.
Insurance
Please select your insurance company (Optional)

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
10-10-2017 03:14 PM
player01
10-10-2017 03:12 PM
player01 Don't know what happened but it appears that my AWD failed (faulty pump) through a sharp curve and my tires all started spinning and i spun. Regained traction right when i was facing a barrier and went into it full bore. Air bag deployed.
Should I try to fix it? How much do you think this will cost to fix? Still waiting to find out if it will be written off.
08-24-2017 08:53 PM
Smeagol Hmm odd still can't put up a pic. I guess you'll have to just use your imagination.
08-24-2017 08:50 PM
Smeagol Sadly, I can add my name to this list.

Last week while on the way to work on the freeway I was rear-ended. Traffic was slowing due to typical jams during that time. The driver behind me apparently wasn't paying attention. They tried to avoid me by swerving quickly to the right, but they did not make it. This is why the damage is on the rear and quarter panel areas on the right. I estimate they hit me at probably 20-25mph but it's really hard to say. They did end up probably 150 ft. in front of me if that tells you anything.

Initial estimate from the body shop was ~$5800. Current estimate is up to $11,800. Currently at the body shop being worked on. I knew it was going to be way higher when I saw the broken suspension bits under the car.

My only concern so far is that they are only replacing the one tire that was damaged, and they only specified a 2 wheel alignment. I though we had to replace all tires when something like this happens? Or at least in pairs. I mentioned this when I first dropped off the car but will ask them about it again tomorrow.

OK, guess I can't post photos/links until I have a postcount...strange, I guess this is my first post.

Thanks.
06-05-2017 11:23 AM
Jikasauto
Quote:
Originally Posted by kidneythief13 View Post
As I’m sure many of you guys know, Ken (aka kge0003) has a lot of useful knowledge about automobile accident damage & claims. Well, he approached me wanting to help those on here involved in collisions even more so. After some discussion with the other staff & Ken, we have decided that he deserves his own stickied thread where those needing such help can obtain information.

So, for those unfortunately involved in an accident or situation in which their Evo X has been damaged, Ken & this thread are here to help you. Basically, you guys can either post your story/question in this thread or link to your pre-existing thread. Ken will then try & help you guys out. Others should of course feel free to post responses as you would in a “normal” thread about someone’s accident.

Thank you very much Ken for helping out on here! It is much appreciated.
Hi guys Iam driving a 2015 Evo X sst with 12000km on the clock. The car was in a accident, after fixing it does not want to crank. The scan tool just give me fault codes like U0001 , B1731. Pls if you guys can help me.
06-02-2017 04:45 AM
logicshiFt I can join this club!

Little bit of backstory, I was stopped waiting for a light. The car behind me got hit by the car behind them, which launched their car into my rear and then my car into the car in front of me. I'd guess at 30-35mph. Seat broke backwards, front and back are junked.



They're currently talking about totaling it, the damage is at like 51% of the value of the car, the shop it's at is saying they will most likely find enough damage to total it when they start pulling panels off. They're willing to, the insurance company just needs to give the go-ahead. Hoping they'll do so soon so I can figure out if it's totaled or not
09-14-2015 04:39 PM
qnet
Quote:
Originally Posted by Learn_More View Post
So, I just had $27,500 of damage repaired on my '14 GSR. It was hit primarily from the back, so the ACD/AYC pump got absolutely destroyed. (The girl was doing about 45MPH when she hit me) The front got beat up pretty bad too because I got pushed into the car in front of me. They replaced the intercooler and crash bar on the front.
Basically all the panels around the car were replaced, except for the doors.
ANYWAY, after sitting in the collision shop for 13 and a half weeks I got it back.
I plugged in my Cobb AP when I got home and read the trouble codes. (I know I should have done this before I even left)
I'm getting:
ACD:
C1612
C161B
C161A
AIRBAG:
U0171
U0170
B1B22

I looked these up and the ACD issues are with voltage/pressure and the Airbag ones are front sensors and one of the side curtains. I get no dash lights though...

What should I do? Can I bring this to Mitsu to diagnose so I can make another claim to my insurance and have them fix it? Unfortunately the closest Mitsu dealer is over 2.5 hours away.
I really don't know what to do.
On Monday I'll have to call my insurance agent and see what he says too.

I just wanted to get some opinions from what you guys would do. I guess the shop couldn't read the codes or whatever. I'm not even sure how they properly installed the damn ACD/AYC pump without the MUTIII.
Wow, they had your car for awhile, you would think after all that time that they would have fixed it correctly. It's coming up on two months for me, and I thought that was long. I'm really hoping my car get's done right. I hate waiting this long because I don't know or trust anyone with my car.

I wish I had took some pictures when I looked at my car, just to get some opinions. I looked at it Aug 31, and it looked like it was very near completion. The body work was done, but the interior needed to be put back together, and on the exterior, the rear wing and right side skirt were off. My right back tire was missing also and the spare donut was in it's place.
09-12-2015 11:04 PM
veles
Quote:
Originally Posted by Learn_More View Post
So, I just had $27,500 of damage repaired on my '14 GSR. It was hit primarily from the back, so the ACD/AYC pump got absolutely destroyed. (The girl was doing about 45MPH when she hit me) The front got beat up pretty bad too because I got pushed into the car in front of me. They replaced the intercooler and crash bar on the front.
Basically all the panels around the car were replaced, except for the doors.
ANYWAY, after sitting in the collision shop for 13 and a half weeks I got it back.
I plugged in my Cobb AP when I got home and read the trouble codes. (I know I should have done this before I even left)
I'm getting:
ACD:
C1612
C161B
C161A
AIRBAG:
U0171
U0170
B1B22

I looked these up and the ACD issues are with voltage/pressure and the Airbag ones are front sensors and one of the side curtains. I get no dash lights though...

What should I do? Can I bring this to Mitsu to diagnose so I can make another claim to my insurance and have them fix it? Unfortunately the closest Mitsu dealer is over 2.5 hours away.
I really don't know what to do.
On Monday I'll have to call my insurance agent and see what he says too.

I just wanted to get some opinions from what you guys would do. I guess the shop couldn't read the codes or whatever. I'm not even sure how they properly installed the damn ACD/AYC pump without the MUTIII.
I would do exactly what you said. Call the insurance, but typically you can send supplemental bills against an existing claim (don't need to make a new claim, they keep them open for a long time). Just have Mitsu write it up that it was due to accident and subsequent incorrect install.

The moment I got my car back from the body shop (not nearly as bad a damage as yours), I took it to Mitsu and had them check that everything was done right. But it's easy for me to say because my dealership is only 15 min away.....
09-12-2015 08:52 PM
Learn_More So, I just had $27,500 of damage repaired on my '14 GSR. It was hit primarily from the back, so the ACD/AYC pump got absolutely destroyed. (The girl was doing about 45MPH when she hit me) The front got beat up pretty bad too because I got pushed into the car in front of me. They replaced the intercooler and crash bar on the front.
Basically all the panels around the car were replaced, except for the doors.
ANYWAY, after sitting in the collision shop for 13 and a half weeks I got it back.
I plugged in my Cobb AP when I got home and read the trouble codes. (I know I should have done this before I even left)
I'm getting:
ACD:
C1612
C161B
C161A
AIRBAG:
U0171
U0170
B1B22

I looked these up and the ACD issues are with voltage/pressure and the Airbag ones are front sensors and one of the side curtains. I get no dash lights though...

What should I do? Can I bring this to Mitsu to diagnose so I can make another claim to my insurance and have them fix it? Unfortunately the closest Mitsu dealer is over 2.5 hours away.
I really don't know what to do.
On Monday I'll have to call my insurance agent and see what he says too.

I just wanted to get some opinions from what you guys would do. I guess the shop couldn't read the codes or whatever. I'm not even sure how they properly installed the damn ACD/AYC pump without the MUTIII.
09-03-2015 03:50 PM
qnet I missed this sticky when I had my accident. Below is a link to my original thread about it (with pics). Long story short, car has right-side damage to back quarter panel, back door, and trunk. Right now repairs have reached a little over $16,000. The body shop has had my car for over a month, and two weeks past their original estimate. They had to replace AYC hydraulic unit in the rear, which apparently took awhile to get.

I really miss my car. I went to look at it Monday, and all the body work was done. The interior was gutted and they are waiting on my right seat to be reupholstered with leather, since my leather was dealer installed.


https://www.evoxforums.com/forums/sho...d.php?t=305249
This thread has more than 10 replies. Click here to review the whole thread.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT. The time now is 08:55 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.