EvoXForums.com - Mitsubishi Lancer Evolution X Forums - View Single Post - Ecuflash stopped working....HELP!!!!
View Single Post
Old 11-01-2012, 06:28 AM  
evox79
Forum Lackey
 
evox79's Avatar
 
Join Date: Oct 2010
iTrader: (100)
Location: San Diego
Posts: 1,515
Ughhh.. I had a bitch of time with ecuflash when I first started tuning back in the spring.. Did you try all this below?


; for Windows XP users we recommend to install the EcuFlash 1.42
; for Vista/Windows 7 users we recommend to install the 1.43 beta version
; accept all defaults when prompted, do not install to a different directory
; best practice is to install EcuFlash first, after drivers are loaded, then plug in the Openport 2.0 (it will install it's drivers)
-------------------Uninstall/Reinstall-------------------
; EcuFlash recommended steps to de-install/re-install to the beta version (1.43)
; steps must be performed in the exact sequence for optimal results
; use the DEEP SCRUB procedure to completely eliminate previous files
1. Make sure the OpenPort cable is NOT connected to your computer
2. In Add/Remove Programs, uninstall all versions of EcuFlash and all drivers with OpenPort, Tactrix, or FTDI in the name. (SEE DEEP SCRUB)
3. In program files, delete the OpenECU folder.
4. Delete any EcuFlash shortcuts that you have on the desktop or elsewhere.
5. Reboot.
6. Download and install the latest version of EcuFlash 1.43 (beta). http://www.tactrix.com/index.php?opt...d=44&Itemid=65. For Vista/Win7 users, right click the EcuFlash installer and select “run as admin”.
7. Plug the OpenPort cable into a USB port on your computer.
8. When Windows asks to connect to windows update, select NO, then select “install the software automatically”. This may occur twice before the driver install is finished.

DEEP SCRUB:
Sometimes the driver just won't work no matter how much you install/uninstall EcuFlash. This happens 1% of the time, and to fix this, you need to go into the c:\windows\inf\ folder and do a windows search "in file contents" for the word FTDI and delete just those specific inf files. (On my PC I found oem10.inf oem11.inf oem12.inf oem14.inf.) Then reinstall from the EcuFlash installer, then it will work.
(Remember x86 means 32bit windows, and x64 means 64bit version of windows.)
On some strange situations, when plugging in the "FTDI USB to Serial COM" cable it pops up a message informing you that the driver was not digitally signed correctly and will be disabled. This can be fixed by going to the c:\windows\system32\drivers folder and deleting ftser2k.sys and then UN-installing the driver, plug the cable back in, and reinstalling if requested, using the FTDI driver that comes with ECUFlash in the drivers folder.
BTW, if you are looking for the drivers, EcuFlash has a spare copy of the drivers in their installation folders in case you need them again.
Here are those folder locations:
32-vit version of Windows ->
C:\Program Files (x86)\OpenEcu\EcuFlash\drivers\openport 1.3\
C:\Program Files (x86)\OpenEcu\EcuFlash\drivers\openport 2.0\
64-bit version of Windows ->
C:\Program Files\OpenEcu\EcuFlash\drivers\openport 1.3\
C:\Program Files\OpenEcu\EcuFlash\drivers\openport 2.0\
double click DPInst.exe to run this driver installation program.
Also if windows asks for a driver folder, you can point it at the right folder above.
Also, make sure that everytime you run Ecuflash, you run it as administrator - you can set it up to do this every time by modifying the EcuFlash
__________________
2008 WW EVO X GSR SSS

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Selling Returning to Stock > GTR in Full Pursuit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
evox79 is offline   Reply With Quote