Engine Idle/Misfire Diagnosis - EvoXForums.com - Mitsubishi Lancer Evolution X Forums
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X General
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

Evo X General General discussion on the 2008+ Mitsubishi Lancer Evolution X

Reply
 
Thread Tools Display Modes
Old 04-30-2019, 03:01 PM   #1
kegbert
n00b
 
Join Date: Apr 2019
iTrader: (0)
Posts: 3
Unhappy Engine Idle/Misfire Diagnosis

Longtime reader, first time poster - all issues I've had before, this forum had the answers I needed - but now I feel my situation is more unique. I've tried to search and follow all the advise in as many posts as seemed even minimally relevant.

About 6 months ago, I started experiencing an intermittent idle problem. The issue was so minor, it wasn't worth the time to try and diagnose, and didn't really affect the car's ability or reliability. I just noticed that the car would misfire once in a while when the throttle was in between adding and removing speed while on the highway. It seemed like it was more likely to happen when it was humid/raining or perhaps at higher altitude. When I would start the car, the idle would bounce a little, running between around 650 and 850.

The issue progressed enough and after switching to an android head unit which allowed me to read my ODB II information whenever, that I started looking into it deeper and tried to slowly progress through the most likely/least expensive/least effort remedies. Here's what I've been able to discover/replace over time:
(My car is basically stock, or started that way for this description of events, following regular service intervals, driven aggressive but not extreme, first owner/bought new from dealer - 2010 Evo X GSR with 78k miles on it now)
- The misfire primarily occurs in cylinder 4, occurring more frequently at idle, at about 1-2 a minute. For my last 10 drives, I average about 45 misfires per drive. All other cylinders average close to 0. While on the highway, in a flat environment and using cruise control, it never misfires.
- I removed, inspected, and cleaned my throttle. Then reset the ECU. Originally it idled high but it learned over time.
- I checked for vacuum leaks, including the common fuel pressure regulator line which I zip tied secured.
- I ran intake cleaner through, then fuel cleaner, ultimately no effect.
- I cleaned, then replaced, my MAF sensor - no change
- I replaced my up and downstream O2 sensors, somewhat as preventative maintenance, which slightly helped in other areas, but didn't affect the problem.
- I changed out my stock intake for a K&M cone with the cold air shield. It sounds awesome, but didn't affect the problem.
- I inspected, then replaced my spark plugs, using the stock NGK ones. No effect.
- I tested each cylinder's compression which had near perfect results.
- I replaced my ignition coils with no effect.
- I resistance tested the fuel injectors, without any discoveries.
- I disconnected vacuum from the master cylinder, to rule out a leak/problem with it, which proved there was no leak there.
- I tested for a head gasket leak, which didn't result in anything.
- I thought about replacing the valve cover gasket, but decided it could wait until I have to dig deeper into the engine for a good reason.
- I ran pressurized air into my exhaust and couldn't discover any exhaust leaks

What I think I could try next, but haven't yet:
- Replacing the cam/crankshaft position sensor(s)
- Replacing the fuel injector if switching cylinder 4's with another's causing the misfires to move. I didn't want to mess with the fuel rail unless I had to.
- Replacing the boost pressure sensor
- Replacing spark plug wires

Has anyone else experienced this same or a similar issue and have any advise? Any information helps and is appreciated.

------

Mode $06 report generated by Torque for Android
================================================

Vehicle VIN: Not present
Vehicle Manufacturer: Unknown
Vehicle Calibration ID: Not present

Test report:
------------------
MID:$01 TID:$81
- O2 Bank 1 Sensor 1
Max: 65,535Count Min: 20Count
Test result value: 32Count
PASS
----
MID:$02 TID:$05
Rich to Lean sensor switch time(calculated) - O2 Bank 1 Sensor 2
Max: 5,900ms Min: 0ms
Test result value: 1,100ms
PASS
----
MID:$02 TID:$08
Maximum sensor Voltage for test cycle(calculated) - O2 Bank 1 Sensor 2
Max: 7.99527V Min: 0.52704V
Test result value: 1.05408V
PASS
----
MID:$02 TID:$82
- O2 Bank 1 Sensor 2
Max: 1.00003V Min: 0.31232V
Test result value: 1.05408V
FAIL
----
MID:$02 TID:$88
- O2 Bank 1 Sensor 2
Max: 500ms Min: 0ms
Test result value: 50ms
PASS
----
MID:$21 TID:$83
- Catalyst Monitor Bank 1
Max: 0.09765Ratio Min: 0Ratio
Test result value: 0Ratio
PASS
----
MID:$35 TID:$89
-
Max: 5 Min: 0
Test result value: 0.7
PASS
----
MID:$36 TID:$89
-
Max: 5 Min: 0
Test result value: 0.05
PASS
----
MID:$39 TID:$85
-
Max: 766.75946kPa Min: 1.9422kPa
Test result value: 1.9422kPa
PASS
----
MID:$3b TID:$85
- EVAP Monitor (0.090")
Max: 1.8837kPa Min: 0kPa
Test result value: 0kPa
PASS
----
MID:$3c TID:$85
- EVAP Monitor (0.040")
Max: 1.3338kPa Min: 0kPa
Test result value: 0kPa
PASS
----
MID:$a2 TID:$0b
EWMA Misfire counts (average) for last 10 drive cycles - Misfire Cylinder 1 Data
Max: 65,535Count Min: 0Count
Test result value: 1Count
PASS
----
MID:$a2 TID:$0c
Misfire counts for last/current driving cycles(calculated) - Misfire Cylinder 1 Data
Max: 65,535Count Min: 0Count
Test result value: 1Count
PASS
----
MID:$a3 TID:$0b
EWMA Misfire counts (average) for last 10 drive cycles - Misfire Cylinder 2 Data
Max: 65,535Count Min: 0Count
Test result value: 4Count
PASS
----
MID:$a3 TID:$0c
Misfire counts for last/current driving cycles(calculated) - Misfire Cylinder 2 Data
Max: 65,535Count Min: 0Count
Test result value: 1Count
PASS
----
MID:$a4 TID:$0b
EWMA Misfire counts (average) for last 10 drive cycles - Misfire Cylinder 3 Data
Max: 65,535Count Min: 0Count
Test result value: 1Count
PASS
----
MID:$a4 TID:$0c
Misfire counts for last/current driving cycles(calculated) - Misfire Cylinder 3 Data
Max: 65,535Count Min: 0Count
Test result value: 2Count
PASS
----
MID:$a5 TID:$0b
EWMA Misfire counts (average) for last 10 drive cycles - Misfire Cylinder 4 Data
Max: 65,535Count Min: 0Count
Test result value: 44Count
PASS
----
MID:$a5 TID:$0c
Misfire counts for last/current driving cycles(calculated) - Misfire Cylinder 4 Data
Max: 65,535Count Min: 0Count
Test result value: 1Count
PASS
----


End of report.
kegbert is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-30-2019, 04:01 PM   #2
Metal_AF
Just Spooling Up
 
Join Date: Aug 2018
iTrader: (0)
Posts: 113
Are you able to log w/evoscan and a wideband? We could probably rule out a few possibilities, and narrow things down a little.



Your fuel pump could be dying, causing things to lean out intermittently.
Metal_AF is offline   Reply With Quote Quick reply to this message
Old 04-30-2019, 04:22 PM   #3
llllBULLSEYE
Member
 
Join Date: Sep 2018
iTrader: (0)
Posts: 39
I'm having a bad idle issue as well just started a few days ago.
does not feel normal idles between 600-700rpm
exactly like this guy in this video https://youtu.be/yv5h6KmKKSU
Also getting random misfire mainly when shifting to 3rd slowly.
I checked my Evap purge solenoid and there is a clicking noise. Feels like
vacuum is getting stuck there, but it's only present after the car has been driven
for a few minutes.
I ordered the evap purge solenoid and check valve from the hose next to it.
You should check yours as well
I will let you know if that solved my issue.
llllBULLSEYE is offline   Reply With Quote Quick reply to this message
 
Old 05-01-2019, 12:31 AM   #4
kegbert
n00b
 
Join Date: Apr 2019
iTrader: (0)
Posts: 3
I don't (yet) have an evoscan - looked into it today and not sure if I should plop $250 bucks on it - what more would it tell me then other free apps?
kegbert is offline   Reply With Quote Quick reply to this message
Old 05-01-2019, 01:55 AM   #5
turismolover22
X-phile
 
turismolover22's Avatar
 
Join Date: Jan 2017
iTrader: (0)
Location: NE Indiana
Posts: 684
Quote:
Originally Posted by kegbert View Post
I don't (yet) have an evoscan - looked into it today and not sure if I should plop $250 bucks on it - what more would it tell me then other free apps?
I was under the impression evoscan was free. Did I miss something?

NVM, forgot if you dont have the cable then you still have to drop 150 ish bucks on one

Last edited by turismolover22; 05-01-2019 at 01:57 AM.
turismolover22 is offline   Reply With Quote Quick reply to this message
Old 05-01-2019, 03:21 PM   #6
Metal_AF
Just Spooling Up
 
Join Date: Aug 2018
iTrader: (0)
Posts: 113
Quote:
Originally Posted by kegbert View Post
I don't (yet) have an evoscan - looked into it today and not sure if I should plop $250 bucks on it - what more would it tell me then other free apps?
Here is an example of what I log via tactrix and evoscan:

https://datazap.me/u/metalaf/pwm-con...38-39-40-41-42

Tactrix also gives you the ability to eTune via ECUFlash with remote tuners... which is something you should probably look into considering your "crankshaft bent while tuning".


Evoscan is either free or like $20.
Metal_AF is offline   Reply With Quote Quick reply to this message
Old 05-10-2019, 08:13 PM   #7
Tsane
Member
 
Tsane's Avatar
 
Join Date: May 2013
iTrader: (0)
Location: Boston, MA
Posts: 70
good luck with finding a solution, I'm having a similar problem but it's a misfire on cylinder 4 and an dead 02 sensor for me.
__________________
EVO X MR

Mods:
Kosmic built HPR10r 10 plate clutch transmission
Dodson heated sump
Dodson trans cooler
Girodisc 2 piece rotors / front and rear
MHI 18k turbo
Radium fuel rail
Synapse bov
Mishimoto uicp
Driven fabrication catch can
Cobb 3 port EBCS
Sakura intake
Sakura tubular manifold
Sakura licp
Sakura 3.5" fmic intercooler
AMS downpipe
TurboXS high flow cat
HKS single exit exhaust
Varis V1 front bumper
Varis carbon v2 lip
HKS GT IV coilovers
Tsane is offline   Reply With Quote Quick reply to this message
Old 05-12-2019, 10:41 PM   #8
mac10190
n00b
 
Join Date: Sep 2018
iTrader: (0)
Location: Houston, TX
Posts: 10
If you're getting good spark you might try replacing the fuel relay, and maybe even the fuel pump. Have you already had your injectors flow tested? And have you done any other modifications to your car besides the intake? Also you might give your mass airflow sensor a clean or even a replacement.
__________________
2015 Lancer Evolution: Final Edition
COBB 3-Port Boost Controller
COBB SF Intake
COBB Airbox
ETS Test Pipe
Custom Duel Exhaust w/ Carven Mid-pipe Muffler
Protune by Kozmic Motorsports (309whp/310wtq) - Mustang Dyno
mac10190 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Security Question
While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what the 2x4 is made of.
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hellephant 1,000-horsepower Mopar crate engine priced, is available to order testdummy Automotive News, Articles & Pics 0 04-26-2019 04:21 AM
Nissan puts legendary RB26 inline-six engine back into production testdummy Automotive News, Articles & Pics 0 03-28-2019 08:52 PM
2020 Toyota Supra getting a CX Racing 2JZ engine swap kit testdummy Automotive News, Articles & Pics 0 02-26-2019 02:11 PM
This carbon-fiber 1970 Dodge Charger packs a 996-horsepower Demon engine testdummy Automotive News, Articles & Pics 0 10-30-2018 07:50 PM
Mercedes-AMG One delayed: Surprise, Formula 1 engine not ideal for emissions testdummy Automotive News, Articles & Pics 0 10-16-2018 03:00 PM


All times are GMT. The time now is 09:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.