HOWTO: Enable Readiness for OBDII inspection after removing your o2 sensor - Page 29 - EvoXForums.com - Mitsubishi Lancer Evolution X Forums
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X Tuning > ECUFlash / OpenECU
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

ECUFlash / OpenECU Subforum for discussion about ECUFlash / OpenECU software and tuning.

Reply
 
Thread Tools Display Modes
Old 01-09-2017, 09:09 PM   #281
razorlab
 
Join Date: Feb 2009
iTrader: (0)
Location: Bay Area, CA
Posts: 5,188
Quote:
Originally Posted by ranaanar View Post
Hey Scott, will your fix solve a "diag incomplete" on an Impreza ?
I had to turn off all secondary air injection diags which now show incomplete.
Impreza? I think your lost...
__________________
Bryan
2014 Evo GSR - E85 powered - 640whp
2018 Golf Alltrack - E35 powered


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
razorlab is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-11-2017, 04:48 AM   #282
Kooldino
Dino
[Approved Merchant]
[Local Team Member]
 
Kooldino's Avatar
 
Join Date: Apr 2007
iTrader: (100)
Location: South Jersey
Posts: 24,190
Quote:
Originally Posted by chetrickerman View Post
59580004

Code:
<table name="Non-Continuous Monitor Completion Patch" category="OBD Inspection" address="910c0" type="2D" level="2" scaling="Hex16">
	<table type="Static Y Axis" elements="2">
		<data>A0BD->6000</data>
		<data>87C2->7000</data>
	</table>
</table>
<table name="Monitor Passed(1)/Failed(0) - Read Only, Do NOT Change" category="OBD Inspection" address="910c1" type="2D" level="2" scaling="blobbits">
		<table name="Non-Continuous Monitor Completion Bits" type="Static Y Axis" elements="8">
			<data>EGR system</data>
			<data>Oxygen heater sensor</data>
			<data>Oxygen sensor</data>
			<data>A/C system refrigerant</data>
			<data>Secondary air system</data>
			<data>Evaporative system</data>
			<data>Heated catalyst</data>
			<data>Catalyst</data>
		</table>
	</table>
Dont adjust any of the other readiness tables, only this one
So if I disable the rear O2 with this patch, I get a P0137, and if i enable it, I get a P0420. What am I missing? Don't I need the other two tables under the OBD-II readiness monitor?
Kooldino is offline   Reply With Quote Quick reply to this message
Old 05-05-2017, 05:36 PM   #283
laksman91
X-phile
 
Join Date: Jan 2010
iTrader: (100)
Posts: 1,156
Getting P0037 after doing this - I didn't disable P0139 or P0140. Is that why?
laksman91 is offline   Reply With Quote Quick reply to this message
 
Old 07-10-2018, 01:16 PM   #284
GSXRiderK6
Forum Lackey
 
GSXRiderK6's Avatar
 
Join Date: Oct 2011
iTrader: (100)
Location: BIFC
Posts: 1,624
Should all the codes for catalyst, rear o2 heater, random misfire, etc. be enabled in the tune; then apply the patch? (Not sure if codes will pop if they are enabled, causing me to fail).

My readiness monitors for cat and o2 read "N/A" on my handheld scanner with codes disabled and patch applied. I feel like they should read "complete" or "pass", if done correctly.
GSXRiderK6 is offline   Reply With Quote Quick reply to this message
Old 07-10-2018, 04:21 PM   #285
GSXRiderK6
Forum Lackey
 
GSXRiderK6's Avatar
 
Join Date: Oct 2011
iTrader: (100)
Location: BIFC
Posts: 1,624
Here's my current readout. Thanks dudes...
Attached Thumbnails
Click image for larger version

Name:	20180710_121735_1531239705378.jpg
Views:	136
Size:	567.9 KB
ID:	278724  
GSXRiderK6 is offline   Reply With Quote Quick reply to this message
Old 03-03-2019, 05:53 PM   #286
Clipse3GT
[Gearhead]
 
Clipse3GT's Avatar
 
Join Date: May 2009
iTrader: (100)
Location: Cleveland, OH
Posts: 6,194
Revive

Anyone seen this message before with Echeck (Emission Service Stations)



I tried new way to pass echeck readiness. All monitors pass and are available.

However, it will not pass due to this message. I tried with 52680015, 52680022, Tephra V1 and Tephra V3. All of them get this same error.

Just wondering if anyone seen this before at any of their stations or just they have a new way of not passing these patches.
__________________
List:
-Clipse3GT Tune -SC Built 2.0 -FP RED -COBB Hardpipes, SFI, Sway Bars -Cosworth MX1 -MDR Inlet -MAP P&P INT. & Full Race EXT.-ETS 4" FMIC -AMS DP, Fuel Rail, MM -T1R Exhaust -MXP TP -FORGE WGA -APS TV BOV -xMR Catch Cans -Walboro 255 -Fuelab FPR -FIC 1100cc -GM 3 Port -Techna-Fit SS Lines -TWM SS/Cage Shifter -WORKS Bushings -Ohlin DFV Coilovers -Whiteline Kit -VEI Gauges -Rally Armor -PERRIN Ant. -Advan RS

Last edited by Clipse3GT; 03-03-2019 at 05:58 PM.
Clipse3GT is offline   Reply With Quote Quick reply to this message
Old 05-19-2019, 04:20 AM   #287
TravisF
Just Spooling Up
 
Join Date: May 2008
iTrader: (100)
Posts: 353
Quote:
Originally Posted by ScottSpeed21 View Post
Ok I just tried this and it works, everything shows Ready like this



I went in and changed the names of the definitions so it makes more sense and everything reads correctly. I also got rid of the Availability portion since we won't change any of that.



If anyone's interested, you'd need to remove all of the current patch definitions and replace it with this

Code:
<table name="Inspection Readiness Patch" category="OBD-II" address="8feb8" type="2D" level="2" scaling="Hex16">
  <table type="Static Y Axis" elements="2">
   <data>A0BD->6000</data>
   <data>877A->7000</data>
  </table>
 </table>
 
 <table name="Inspection Monitor - Passed(0)/Failed(1) - READ ONLY Do NOT Change" category="OBD-II" address="8feb9" type="2D" level="2" scaling="blobbits">
  <table name="Non-Continuous Monitor Completion Bits" type="Static Y Axis" elements="8">
   <data>EGR system</data>
   <data>Oxygen heater sensor</data>
   <data>Oxygen sensor</data>
   <data>A/C system refrigerant</data>
   <data>Secondary air system</data>
   <data>Evaporative system</data>
   <data>Heated catalyst</data>
   <data>Catalyst</data>
  </table>
 </table>
Big thanks for this! I had my first and last emissions test in WA and passed easily with this patch.

TravisF is offline   Reply With Quote Quick reply to this message
Old 07-13-2019, 08:40 PM   #288
Ralliartist
n00b
 
Join Date: Aug 2014
iTrader: (0)
Posts: 16
Can someone tell me if these settings are right for 59580004? The main thing that I'm questioning is that the Monitor Available Settings didn't change to all 1s after making the changes to the two non-continuous patch tables.

[IMG]https://photos.app.*******/b1VLGzS1SDptv4g96[/IMG]

Last edited by Ralliartist; 07-13-2019 at 08:42 PM. Reason: Fix pic link
Ralliartist is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Security Question
While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what the 2x4 is made of.
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SST OBDII Codes & Info saytheb SST 34 06-11-2019 02:23 PM
blitz sbc temp sensor and pressure sensor can slot in zeitronix zt2? superlemonevo Evo X General 1 04-10-2010 04:17 PM
Removing Rear 02 Sensor Completely hotdog Evo X Engine (4B11T) 7 02-24-2010 05:43 PM
Inspection dminor04 Evo X General 8 02-24-2010 04:28 PM
P0135 02 Sensor Heater Circuit Malfunction (Bank 1 Sensor 1) evodicted Evo X Engine (4B11T) 3 03-28-2009 12:11 PM


All times are GMT. The time now is 10:07 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.