P1025 - Exhaust engine oil control valve circuit - EvoXForums.com - Mitsubishi Lancer Evolution X Forums
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X Engine (4B11T)
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

Evo X Engine (4B11T) Discussion for engine systems that are unique to the Evo X. IF THE TOPIC IS COMMON WITH OTHER LANCERS, PLEASE POST IT IN: '08+ Lancer Common.

Reply
 
Thread Tools Display Modes
Old 06-06-2019, 01:28 AM   #1
ombitsmike
Just Spooling Up
 
ombitsmike's Avatar
 
Join Date: Dec 2014
iTrader: (0)
Location: Nashville, TN
Posts: 148
Angry P1025 - Exhaust engine oil control valve circuit

I've searched on here and evolutionm forums and couldn't find a definitive answer to this fix while reading it could be a faulty wiring harness to a bad valve/solenoid. I swapped the exhaust oil feeder solenoid and the CEL went away after it idled for 5mins but it came back after I took it for a quick drive around the block and parked it in the shop garage.

Long story short: blew old motor (no cel) a year ago and just recently swapped it with a healthy, used one. It starts, idles, drives beautifully. Nothing was changed between the motors MINUS new OEM Engine gaskets.

Thanks guys! I really need to get this fixed. I've held off my etune with Chet far too long and I can't get my tags renewed with it.
ombitsmike is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-06-2019, 08:10 PM   #2
turismolover22
X-phile
 
turismolover22's Avatar
 
Join Date: Jan 2017
iTrader: (0)
Location: NE Indiana
Posts: 757
Quote:
Originally Posted by ombitsmike View Post
I've searched on here and evolutionm forums and couldn't find a definitive answer to this fix while reading it could be a faulty wiring harness to a bad valve/solenoid. I swapped the exhaust oil feeder solenoid and the CEL went away after it idled for 5mins but it came back after I took it for a quick drive around the block and parked it in the shop garage.

Long story short: blew old motor (no cel) a year ago and just recently swapped it with a healthy, used one. It starts, idles, drives beautifully. Nothing was changed between the motors MINUS new OEM Engine gaskets.

Thanks guys! I really need to get this fixed. I've held off my etune with Chet far too long and I can't get my tags renewed with it.
Possible short to the MIVEC solenoid?
turismolover22 is offline   Reply With Quote Quick reply to this message
Old 06-07-2019, 05:10 AM   #3
ombitsmike
Just Spooling Up
 
ombitsmike's Avatar
 
Join Date: Dec 2014
iTrader: (0)
Location: Nashville, TN
Posts: 148
Quote:
Originally Posted by turismolover22 View Post
Possible short to the MIVEC solenoid?
I'll check it out tomorrow with a voltmeter. And gonna try a new control valve. Checked datalogs and both cams are spot on with Target to Actual
ombitsmike is offline   Reply With Quote Quick reply to this message
 
Old 06-07-2019, 02:37 PM   #4
DoubleClutch
n00b
 
DoubleClutch's Avatar
 
Join Date: Sep 2018
iTrader: (0)
Location: Canton, MI
Posts: 14
Try this out.

From the factory service manual.
Attached Files
File Type: pdf P1025 Troubleshooting Guide.pdf (262.0 KB, 27 views)
DoubleClutch is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Security Question
While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what the 2x4 is made of.
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:17 AM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.