UR Down pipe & Test pipe.... small problem - EvoXForums.com - Mitsubishi Lancer Evolution X Forums
EvoXForums.com - Mitsubishi Lancer Evolution X Forums
Go Back   EvoXForums.com - Mitsubishi Lancer Evolution X Forums > Evo X > Evo X Performance
Home Register Forum Store Members List Calendar Auto Loans vBGarage Photo Gallery Search Today's Posts Mark Forums Read Auto EscrowInsurance

Evo X Performance General discussion for performance topics that are unique to the Evo X. IF THE TOPIC IS COMMON WITH OTHER LANCERS, PLEASE POST IT IN: '08+ Lancer Common.
Sponsored by:

Reply
 
Thread Tools Display Modes
Old 07-20-2008, 04:24 AM   #1
proracer718
Just Spooling Up
 
proracer718's Avatar
 
Join Date: Apr 2008
iTrader: (100)
Location: Newark, NJ
Posts: 542
UR Down pipe & Test pipe.... small problem

Well I recently bought the Ultimate racing DP and TP. I have to say the product does look very nicely made. I went with UR one cause I have been reading no one had a problem with them.

After installing both parts and making sure everything was nice and tight I turn the car on and you can hear the difference. Car now is a bit louder but has a deep rumble to it which I love. After letting it idle for about 10 mins and reving it up a bit I go for a ride and you feel the response right away. The car feels smoother to redline and sounds mean.

So after about 30 miles after the install I am going home and step on it and all of a sudden a check engine light comes on and the car sounds different and feels like S**t. So I take it easy and park it and wait till the next day to put it on the lift which I did to check if maybe a bolt came loose or something but everything was fine. Check to see if I had an exhaust leak but didn't notice anything. I disconnected to batter to reset and once I turned the car on the light was not on anymore. So I go for a drive and it doesn't feel right. The car is very sluggish and now when I stop at a light the idle sometimes is everywhere and car even wants to shutoff at times.

My question is, is there anyway that maybe I can check for an exhaust leak with a tool or something? Also what can be causing the problem I have now even though I don't have a check engine light?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
proracer718 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-20-2008, 03:38 PM   #2
proracer718
Just Spooling Up
 
proracer718's Avatar
 
Join Date: Apr 2008
iTrader: (100)
Location: Newark, NJ
Posts: 542
Any thoughts or suggestions????
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
proracer718 is offline   Reply With Quote Quick reply to this message
Old 07-20-2008, 06:35 PM   #3
hameedosh
Just Spooling Up
 
hameedosh's Avatar
 
Join Date: Sep 2008
iTrader: (0)
Location: kuwait
Posts: 354
i was planing on buying these 2 pipes, i'll wait for an answer as well
__________________
"every man has a dream car.... this is mine"
the first Evo X in kuwait

Powered by Buschur Racing
Ported by MAPerformance
Built and Tuned by Panda Performance
hameedosh is offline   Reply With Quote Quick reply to this message
 
Old 07-20-2008, 08:01 PM   #4
Papi4baby
Just Spooling Up
 
Papi4baby's Avatar
 
Join Date: Jul 2008
iTrader: (100)
Location: MD
Posts: 457
Did you try what i sugested on the other forum?
Papi4baby is offline   Reply With Quote Quick reply to this message
Old 07-21-2008, 06:37 AM   #5
hameedosh
Just Spooling Up
 
hameedosh's Avatar
 
Join Date: Sep 2008
iTrader: (0)
Location: kuwait
Posts: 354
Quote:
Originally Posted by Papi4baby View Post
Did you try what i sugested on the other forum?
which forum ??
__________________
"every man has a dream car.... this is mine"
the first Evo X in kuwait

Powered by Buschur Racing
Ported by MAPerformance
Built and Tuned by Panda Performance
hameedosh is offline   Reply With Quote Quick reply to this message
Old 07-21-2008, 06:55 AM   #6
untuned
n00b
 
Join Date: Sep 2008
iTrader: (0)
Posts: 10
Quote:
Originally Posted by proracer718 View Post
Well I recently bought the Ultimate racing DP and TP. I have to say the product does look very nicely made. I went with UR one cause I have been reading no one had a problem with them.

After installing both parts and making sure everything was nice and tight I turn the car on and you can hear the difference. Car now is a bit louder but has a deep rumble to it which I love. After letting it idle for about 10 mins and reving it up a bit I go for a ride and you feel the response right away. The car feels smoother to redline and sounds mean.

So after about 30 miles after the install I am going home and step on it and all of a sudden a check engine light comes on and the car sounds different and feels like S**t. So I take it easy and park it and wait till the next day to put it on the lift which I did to check if maybe a bolt came loose or something but everything was fine. Check to see if I had an exhaust leak but didn't notice anything. I disconnected to batter to reset and once I turned the car on the light was not on anymore. So I go for a drive and it doesn't feel right. The car is very sluggish and now when I stop at a light the idle sometimes is everywhere and car even wants to shutoff at times.

My question is, is there anyway that maybe I can check for an exhaust leak with a tool or something? Also what can be causing the problem I have now even though I don't have a check engine light?
I have the UR downpipe and test pipe installed and didn't have a problem. did you check what dtc you got? I have a idling issue too, but that was before my exhaust was installed. I believe there is flash for the fix, but just not in canada just yet. is the 02sensor plugged back in?
untuned is offline   Reply With Quote Quick reply to this message
Old 07-21-2008, 07:19 AM   #7
proracer718
Just Spooling Up
 
proracer718's Avatar
 
Join Date: Apr 2008
iTrader: (100)
Location: Newark, NJ
Posts: 542
Quote:
Originally Posted by untuned View Post
I have the UR downpipe and test pipe installed and didn't have a problem. did you check what dtc you got? I have a idling issue too, but that was before my exhaust was installed. I believe there is flash for the fix, but just not in canada just yet. is the 02sensor plugged back in?
I didn't get to check what code the car is throwing but will do so asap since the car is going to the body shop today. Both sensors were put back in there correct locations.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
proracer718 is offline   Reply With Quote Quick reply to this message
Old 07-28-2008, 04:58 PM   #8
proracer718
Just Spooling Up
 
proracer718's Avatar
 
Join Date: Apr 2008
iTrader: (100)
Location: Newark, NJ
Posts: 542
Well Finally got the car back from the body shop a few days ago and finally got to take it to autozone to check the codes.

Here are the codes that came up.......

P0137
P0131
P0102

Any help on what I should do to fix this problem is greatly appreciated.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
proracer718 is offline   Reply With Quote Quick reply to this message
Old 07-28-2008, 05:21 PM   #9
Kwiq Niss
Just Spooling Up
 
Kwiq Niss's Avatar
 
Join Date: Apr 2008
iTrader: (0)
Location: NC at the Lake
Posts: 375
you have to do the defouler trick with the sensor. It is reading funny since you have the test pipe and ECU thinks something is wrong with the cat. plenty of info was posted for high flow cat CEL fix
__________________
Current:
2008 GG Evo X GSR, Mud Flaps, AMS Performance CAI w/ K&N cone, Oil Catch Can, 35%(NC legal limit)SolarGard tint, Eibach Pro-Kit springs, Nav

To go:
Turbo back exhaust, cams w/ gears, larger FMIC and IC pipes, Electronic Boost Controller, Pulstar Plugs, ECU, Clutch/Flywheel combo, Engine build, head, Turbo with exhaust Mani (prolly GT35R twin-scroll kit), Intake Mani, Fuel, Body kit, Rear Sway Bar, Lighter wheels, Non plastic looking E-brake handle, CAMP2, Tein Coilovers with EDFC

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Kwiq Niss is offline   Reply With Quote Quick reply to this message
Old 07-28-2008, 08:50 PM   #10
joey
Dr. Evo?
 
joey's Avatar
 
Join Date: May 2008
iTrader: (100)
Location: Somewhere over seas
Posts: 22,717
those codes arent for the cat though... are they? the code i threw with my test pipe was like P1320 or some shit. i thought that UR had the cell fix? anyway if thats the case then id buy the anti fowlers at least i did and it seems to work



__________________
--I have the itch to get back into something. Just don't know what yet......
joey is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the EvoXForums.com - Mitsubishi Lancer Evolution X Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Security Question
While balancing on a piece of wood, two inches by four inches known as a 2x4, john and his friend sally both spotted a dalmatian inside a truck with sirens, headed to put out a fire. State what the 2x4 is made of.
Insurance
Please select your insurance company (Optional)

Log-in


Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:34 PM.



Powered by vBulletin® Copyright ©2000 - 2019, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Shoutbox provided by vBShout v6.2.1 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd. Runs best on HiVelocity Hosting.