Mitsubishi Lancer Evolution Forum banner
amp
1-6 of 6 Results
  1. Evo X General
    Ride an Evo 10. To change a genuine all-in-one audio and navigation. But there is a problem You can not find the audio amp turn on wiring in the wiring Wiring two pink + blue wires connected also found, but not getting to work. I can not hear at all. EVO 10 is a Rockford Fosgate audio-based...
  2. Evo X General
    Hey guys I put a new sub in and when doing it I cut my RF amp wire harness and had to get a new one, I put the new harness in and now I have no sound at all? My head unit still works as In turns on and everything, my fuses are fine also, when I turn my car on the sub hits for a second not that...
  3. Evo X Vanity
    2 Inifinty Kappa Perfects 10.1's Dual Ported Box Kicker ZX1000.1 Audiocontrol LC2i
  4. '08+ Lancer Common Electronics & Audio
    So stock non RF speakers suck. Lets get that out of the way. I am planning on upgraded my sound system, amp/receiver first, then speakers (no sub planned). Don't need anything crazy, mainly looking for some more volume. I know the factory HU also is the amp. So if I upgrade to a double din...
  5. Evo X General
    My Evo hits the tarmac at AMP track map and images...
  6. '08+ Lancer Common Electronics & Audio
    Hi guys, So im having some issues with my new setup. I currently have a pioneer Avic-x930bt with the mito harness and factory speakers. My two issues are 1. i have alternator whine and no matter what i do i cant get rid of it. 2. During certain songs and having the volume high it results in my...
1-6 of 6 Results
Top