Mitsubishi Lancer Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hey guys, been trying to find this issue on here and can’t seem to find one that matches mine. So here’s what’s going on. I have a 2011 GSR, fbo, 18k turbo, tuned on 91. The car will idle perfectly normal and drive normal some days, then other days the idle will be very erratic and stall out when I put it in neutral. I’ve replaced the o2 sensor, spark plugs, fuel pump relay, checked all hoses and clamps. Can’t seem to pinpoint the issue. No CEL. Any idea of what may be causing this? Possibly tune related? I’m in stock fuel injectors and pump as well no e85. It is driving me nuts. Car will drive fine even when the idle is all out of whack however you can feel the power change when driving like the vacuum/boost level will change about 3-4 psi while cruising. Any help would be appreciated.
 

·
Registered
Joined
·
187 Posts

Good things to check in here. But it seems like you did alot of them already. So maybe buy some MAF cleaner from a parts store and try that? Change/inspect the fuel filter?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Forgot to mention I have cleaned the Maf as well. The start up today was pretty bad and fluctuating idle quite a bit. Stalled out on me twice while in neutral too. Gave it a tad bit of gas when starting it to even out the idle and it warmed up fine however once I started driving and came to a stop, erratic idle. It’s becoming more consistent now rather than out of the blue.


Good things to check in here. But it seems like you did alot of them already. So maybe buy some MAF cleaner from a parts store and try that? Change/inspect the fuel filter?
 

·
Registered
Joined
·
187 Posts
Have you ever changed the fuel pump?
Looking at searches, there are quite a few people that had similar issues and it ended up being pump related.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
I actually have a walbro 450 waiting to be installed, I’m going to boostin performance on the 27th of this month to have them install that and retune the car so I’m hoping that fixes it.

Have you ever changed the fuel pump?
Looking at searches, there are quite a few people that had similar issues and it ended up being pump related.
 

·
Registered
Joined
·
77 Posts
Do you have an aftermarket intake as well as the turbo? Does it have a shield blocking the AC fan from the air filter? Does the erratic idle only happen while the AC and/or defrost is on?
 
1 - 6 of 6 Posts
Top