Mitsubishi Lancer Evolution Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1 (Edited)
Air Conditioner A/C Idle RPM Problem. [SOLVED]

Hello,

I Own EVO X MR with SST trans. Due to a mistake I've uploded an USDM rom to my car but mine is European I returned to stock after one drive through because the car was handling funny. And from them on when ever the car is Idle and A/C is turned on the rpm fall down to 200 and go back to 1000 until the car dies after 4-5 min. Mechanicaly the compressor and everything is ok It's been checked refilled and everything in the shop and it works if you drive around. So far the shop sees that there are 2 functions that hold the RPMs one is for low load and one for high both of them are disabled for some reason when we connect to the OBD port we can turn on only the function of the low load then the RPM sticks on 1000rpm but as soon as u unplug the cable it goes down again. Didn't have any problems with the car before I put the wrong ECU and apparently disabled some A/C TPS systems.

Things I've tried so far:

1. Reset all fuel trims by unplugging the batter and also using evoscan
2. Reset all fuel trims from battery turn the car on ignition start it for few seconds without any electrical things hooked up and then turn it off, I do this one more time, and on the 3rd time I leave it for 15 mins.
3. Unplugging the compressor cable turning on the car putting the A/C on waiting for 2-3 minutes turning off the car plugging the compressor cable in again

So far nothing has worked, the guys at the shop have MUT 3 cable says everything is ok I've asked if they can reprogam the A/C like a clean install they said only if there is a new version which there isnt. Here are the links to both my stock ROM and the one that was mistakenly put on the car. If anyone can help I will pay for the help :) Because all that is left for me to change the whole damn ECU.
 

Attachments

·
Registered
Joined
·
8 Posts
Discussion Starter #3 (Edited)
Ok so after few months no one in my country could figure it out:) . So I bought an american Air conditioner / Heater ECU for 30$ and changed it and it the car was perfect again. I think what happened is this:
1. When my Tactronix cable failed it fried something in the A/C ecu or just scrambled the software beyond repair (at least for the people in Mitsubishi in my country) and new a/c ecu obviously fixed that.

Anyway if anybody else has this kind of problem you know how to fix it now :) The A/C ecu used in the EVO X is also used in citroens and many other cars so they are easy to find.

Update: It seems it only worked for the first start of the car after I unhooked and hooked the battery again, when I turned off the car and started it again the problem was still there. So the struggle continues my next step will be to change the entire ECU I've already ordered 1 new ECU.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
If you mean to remove the battery turn the ignition on fire the engine keep the car for 20 secs turn it off, turn it on again fire up the car for 20 secs again turn it off, and on the third time you turn it on and fire up the engine u keep it for 15 min and then turn on the A/C ? Cause i've done that and it doesn't help
 

·
Registered
Joined
·
12 Posts
If you mean to remove the battery turn the ignition on fire the engine keep the car for 20 secs turn it off, turn it on again fire up the car for 20 secs again turn it off, and on the third time you turn it on and fire up the engine u keep it for 15 min and then turn on the A/C ? Cause i've done that and it doesn't help
any news? same problem, happens after car stay 2 weeks without battery (
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Sorry no fix yet I am trying one last thing from a tuner this weekend and then I am ordering a new ECU.
 

·
Registered
Joined
·
6,345 Posts
Dude, you are throwing money at the car without understanding what's happening...

Start with bench flashing your ECU back to stock and see if problem persists. Why get new ECU, tactrix doesn't just fry a ECU, also, fried ECU behaves way more violently then just what you described.

Bench flash to stock first and report back.

http://www.evoxforums.com/forums/showthread.php?t=29820
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
This is a new info. So I get all the wires and mechanical stuff but why are they needed ? I mean why can't you just put the tactrix cable and do the reflash as explained? This seems like good way to brick my ECU to be honest. Anyway I am going to write a message to the dude to explain some more.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #10
Solved

SOLVED


Ok so after many tries and errors. The fix was that my throttle valve which is near the BOV was very dirty after cleaning that up and removing the battery for few minutes the ECU got the right RPM and now it idles perfectly. It seems that this happens when you put new rom in the car because then it auto resets the values and if it's dirty then it can't get the right ones. For everyone who have the same problem this is the fix :)
 

·
Registered
Joined
·
6,345 Posts
Good that you solved it. Thanks for sharing the info on the solution.

As for bench-flashing, that's the only way to recover a bricked ECU if nothing else helps.
 

·
Registered
Joined
·
4 Posts
I had problems with A/C conditioner every year and I tried everything but nothing worked. When I was driving fast, it didn't work `and this made me nervous on hot days. One of my friends advised me to go A/C repair services where can solve my problem. I went there but I hadn`t any hope that they would repair it. I am happy now because I can drive fast and it doesn't break up anymore.
 

·
Registered
Joined
·
3 Posts
I had problems with A/C conditioner every year and I tried everything but nothing worked. When I was driving fast, it didn't work `and this made me nervous on hot days. One of my friends advised me to go aircon service singapore where can solve my problem. I went there but I hadn`t any hope that they would repair it. I am happy now because I can drive fast and it doesn't break up anymore.

Oh, Go to the repair service and consult with them. I think it will be much cheaper and one hundred percent more correct. I just imagine how expensive it all comes out. I had something similar. I gave my wife a car. After a short time, she pressed something wrong in the car and the climate control stopped working. She was afraid to tell me, because she thought I would get very angry. In the end, she tried to figure it out herself. As a result, she stupidly broke the air conditioner. She had decided to tell me. I was angry, of course, but I contact aircon servicing as soon as possible. They quickly replaced everything for me. But I spent a lot of money on air conditioning.
 
1 - 14 of 14 Posts
Top