Mitsubishi Lancer Evolution Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi guys. First post here but I just bought an an 09' gsr so I'd love to meet the community!

I recently killed my stock o2 sensor. I believe I either dropped it or broke the wire or something while I was installing my downpipe. After checking with the dealer for a price I immediately decided I wasn't going that route ($670 Canadian) so I went to my local junk yard and found a Lancer 9 that still had the sensor on it.

I did a bit of digging and what I got out of it is that all o2 sensors do the same thing, they just have different wire connectors? Correct me if I'm wrong there.

So I figured the $11 bucks for the used one and some soldering was well worth my time. That one lasted for about 2 weeks, but did seem to work for a while before it failed too. I put that up to it already having an unknown amount of kms on it and all the bumps it received pulling it out...are there any other reasons that o2 sensors fail?

Either way I just bought the cheapest one I could find on Amazon for $150 Canadian, I can post a link if anyone is interested. But it's been 2 months now and still going strong.

The part numbers aren't the same, but here are the pictures of the stock one and the Amazon one. It's working so far and it was 520 dollars cheaper.
288023

The old one - DENSO 149100 6664 12J11
288024

The new one DENSO E-B327 06D26

Hope this saves someone some money!

Cheers, Kabre
 
1 - 1 of 1 Posts
Top