Mitsubishi Lancer Evolution Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi,
I recently got my car tuned with full bolts ons about a week ago. Yesterday I was doing a pull and my ASC service required light came on. After awhile of normal driving my service 4wd system then came on. I stopped at Quickcheck, put air in my tires then turned the car back on. The lights were gone, then I finished driving home and the light came on again. I read the codes with my code reader and they read:
C1000- Abnormality in stoplight switch
C1290- CAN timeout error
U0100- Engine CAN timeout

The car drove fine, no signs of anything being wrong. It is a 2014 with 19,000 miles. Can anyone shed some light? I'm tuned at 26 lbs. thank you in advance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
When I turn the car off, then turn it back on, the light is gone. But after driving 15-25 miles it came back on
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Yes I have an aem boost gauge. I did read that it can trigger the ASC service required if I hit 28.5 lbs. I'll have to watch the gauge next time I drive the car. I was wondering if I could potentially damage anything driving the car with the light on
 

·
Registered
Joined
·
957 Posts
dead thread bump
I m having the same code c1000, changed the brake switch but didn't fix the issue.
how can overboost pop the brake light switch code? I am having the code while under normal driving, not WOT. in fact, my asc/awc lights pop on when I depress the brake hard. is this sound like overboost issue?
 
1 - 7 of 7 Posts
Top