Mitsubishi Lancer Evolution Forum banner
1 - 20 of 32 Posts

·
Registered
Joined
·
1,206 Posts
Discussion Starter · #1 ·
so this happened once before. when i first experienced this, i thought the tire slipped and the traction kicked in. the road had a patch of wet surface and i was wot in 4th.

well last night, i was wot in 5th gear at around 4.5k rpm and the same thing happened. this time, i was paying attention so i know the tires didn't slip. and just to confirm, i did it twice. it doesn't seem to happen in the exact rpm range, it varies a little. however, its def in the 4-5k range. it felt like the fuel was cut for a split second. but this doesn't happen in 1st, 2nd, or 3rd gear. last night, it happened in 5th and the first time it happened, it was in 4th.

my car is running rich currently (around 10.2 at wot). what could've caused this? is it because i'm running too rich?

my car is tuned but not professionally. i have intake, exhaust, tp, and uicp.
 

·
Registered
Joined
·
3,043 Posts
I know I say this every time I see something like this, but check your FPR hose. I had identical symptoms when mine came off. 1st and 2nd gear felt ok, but 3rd and 4th would cut fuel between 4-5k. I thought my clutch was slipping. Thank god I checked. And if it's cutting fuel, I doubt you'd have time to get a good A/F reading. Just a thought.
 

·
Registered
Joined
·
2,991 Posts
if it feels a bit like the traction control has cut in, it will be boost cut, You are probably over boosting.
 

·
Registered
Joined
·
8,771 Posts
What plugs are you running? I also had something that felt like boost cut when I was running the HKS SuperFire plugs, it was spark blowout though. It felt exactly like a slipping wheel and was audible.
 

·
Registered
Joined
·
1,206 Posts
Discussion Starter · #13 · (Edited)
Are you sure the AFR's were at 10.2 when this happened? Also, how much fuel was in the tank?
no, i have no idea what the af ratio was at the time. i was not looking at my af gauge. thats how my car's been running.

full tank of gas. i know what you're talking about. i've done wot in 1st gear with very little gas resulting in gas cut-off.
 

·
Registered
Joined
·
1,206 Posts
Discussion Starter · #14 ·
I know I say this every time I see something like this, but check your FPR hose. I had identical symptoms when mine came off. 1st and 2nd gear felt ok, but 3rd and 4th would cut fuel between 4-5k. I thought my clutch was slipping. Thank god I checked. And if it's cutting fuel, I doubt you'd have time to get a good A/F reading. Just a thought.
FPR hose is that little black hose that seems to pop off on all evo x's right? if so, it's already been zip-tied a long time ago so that cant be the issue.
 

·
Registered
Joined
·
1,206 Posts
Discussion Starter · #15 ·
could this be related to stretched chains? i have 64k miles on my gsr right now. i've been reading on the time chain issue and can't help but worry. i have this tendency to let off the gas peddle too suddenly at times.
 

·
Registered
Joined
·
2,991 Posts
take off the valve cover and have a look. It dosn't sound like you have a timing chain issue IMO.

That flutter you describe is normal.
 

·
Registered
Joined
·
2,991 Posts
any updates on this one?
 

·
Registered
Joined
·
14,174 Posts



 

·
Registered
Joined
·
2,991 Posts
lol.... that bad?? lol
 
1 - 20 of 32 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top