Mitsubishi Lancer Evolution Forum banner
1 - 20 of 46 Posts

·
Registered
Joined
·
93 Posts
Discussion Starter · #1 ·
I was looking at this thread
http://forums.evolutionm.net/evo-x-how-tos-installations/374707-evo-x-boost-gauge-install-no-splicing-no-firewall-drilling-pics-vid-clean-hell.html

and searched few others but "fuse tap" solution doesn't work for me for some reason. I tried two different fuse taps but no power when it's connected to the accessory fuses..

Is there any other place that I can tap for accessory power? I have no problem with constant or ground connection since I can use my dome light for that(as I did for my radar detector)..

Any help would be highly appreciated.

Thanks
 

·
Registered
Joined
·
93 Posts
Discussion Starter · #3 ·
Are you using an Add-a-fuse?

If so, do you have two fuses plugged into the add-a-fuse?
yes I meant to say add-a-fuse :D, I have one fuse plugged into the one add-a-fuse there are,however, two slots on each add-a-fuse. Not sure why
 

·
Registered
Joined
·
5,593 Posts
just wrap the positive wire of the boost gauge to the fuse of the 12volt adaptor/cig lighter and stick it in. Thats what i did and its been working fine.
 

·
[NEEvo President]
Joined
·
15,153 Posts
Any help would be highly appreciated.

Thanks
See the Fuse box Diagram below (this is the one in the car). You need a 10 Amp fuse for the extra slot in the fuse tap (its inline with the wire lead). Make sure you place the one you remove into the other slot. Use Fuse 3 for Constant +12V(if needed) and Fuse 13 for switched +12V.




 

·
Registered
Joined
·
776 Posts
i got a question i use "add a fuse" thingy and plug it in fuse 3 and 13 but now my gauges wont turn off. it just light up but wont be off when i turn the car off. any help? btw i have the prosport evo gauges.
 

·
[NEEvo President]
Joined
·
15,153 Posts
i got a question i use "add a fuse" thingy and plug it in fuse 3 and 13 but now my gauges wont turn off. it just light up but wont be off when i turn the car off. any help? btw i have the prosport evo gauges.
Every gauge is different, some require constant some only need switched. If your gauge will not power off with the car then you should disconnect Fuse 3 (+12V Constant).
 

·
Registered
Joined
·
776 Posts
Every gauge is different, some require constant some only need switched. If your gauge will not power off with the car then you should disconnect Fuse 3 (+12V Constant).
i did but it wont power up anymore...
 

·
Registered
Joined
·
776 Posts
oh no i didnt fry my gauge, if i take out fuse 3 where should i connect it to?
 

·
Registered
Joined
·
776 Posts
1 - 20 of 46 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top