Mitsubishi Lancer Evolution Forum banner

21 - 40 of 46 Posts

·
Registered
Joined
·
13 Posts
ok... yeh my program does both ;)
So to sum up, MUT3 input a VIN number with the old one and your program erases to old one and replaces it with the new one?

Then with your program does it matter what type of ECU? I suppose you also change the year?
 

·
Registered
Joined
·
25 Posts
Just a note on this, if you want to use a GSR ecu on a MR or a MR ecu on GSR, you have to copy one thing that's called engine coding. This coding tells that your car is manual or automatic, 4WD or 2WD...

Here are the spteps to do this:

On the MUT-III:
Sys select
Select MFI
Coding
Save to file

Install the new ecu.

Write the VIN into the new ecu.

On the MUT-III:
On vehicule Coding
Enter Your VIN
Select the file
Clic on Check icon
 

·
Registered
Joined
·
13 Posts
Just a note on this, if you want to use a GSR ecu on a MR or a MR ecu on GSR, you have to copy one thing that's called engine coding. This coding tells that your car is manual or automatic, 4WD or 2WD...

Here are the spteps to do this:

On the MUT-III:
Sys select
Select MFI
Coding
Save to file

Install the new ecu.

Write the VIN into the new ecu.

On the MUT-III:
On vehicule Coding
Enter Your VIN
Select the file
Clic on Check icon
Where is my engine coding?

and thanks... Same step to change NA ecu?
 

·
Registered
Joined
·
13 Posts
I am reviving this thread just in case anyone needs to know, you CAN use a GSR ECU in a MR and vice versa.

You just need to bench the rom on to the ECU had have it VIN coded after you bench the ECU.

Follow these steps to program the new VIN

1. Launch MUT3 program.
2. Select "System select".
3. Enter type/year of vehicle under vehicle selection.
4. Connect computer to VCI and to vehicle (blue cable), switch vehicle ignition on.
5. Select KOS/IMMO/Keyless; a new options list will appear.
6. Checked the appropriate options set "VF3 - IMMOBI & Keyless & TPMS".
7. Click Check mark icon on green toolbar at the bottom right
8. Select "Special function".
9. Choose "ENG Key Code &Chassis No/VIN Reg"
10. Click Check mark icon on green toolbar at the bottom right
11. Enter the chassis VIN you want to program the ECU to
12. Click Check mark icon on green toolbar at the bottom right

How much time should this take?

Thanks
 

·
Registered
Joined
·
13 Posts
Did all steps... Still cant flash. ECU flash says there are differences in "areas" and can flash...


Any thoughts?

It does however tell me my 2010 vin...

Bench flash?
 

·
Registered
Joined
·
25 Posts
Did all steps... Still cant flash. ECU flash says there are differences in "areas" and can flash...


Any thoughts?

It does however tell me my 2010 vin...

Bench flash?
Did you read my how to? It will answer all you questions:
http://www.evolutionm.net/forums/la...s/705493-how-install-evo-x-ecu-na-lancer.html

If you are not able to flash your rom in the car, you must remove your ecu and do a bench flash. If you are not able to bench flash the evo x rom, you have to use an older EcuFlash version. The best Version to bench flash is Version 1.43. The newer version will only flash roms with the same first 4 digits. For example: If your car original rom ID is: 54410003, it will only flash rom IDs that's start with 5441... With the 1.43 Version, you can flash any rom into any ecu. Remember, when you do a bench flash, you must do it in recovery mode first and then flash it in normal mode.
 

·
Registered
Joined
·
13 Posts
This is what I get:

EcuFlash Version 1.43.3150</p>
OS Version Windows 7</p>
Qt Version 4.6.2</p>
< 62 memory models read.</p>
scanning for metadata models in C:/Program Files/OpenECU/EcuFlash/rommetadata</p>
553 ROM metadata models scanned.</p>
checksum module "subarudbw" loaded.</p>
checksum module "mitsucan" loaded.</p>
checksum module "mitsuh8" loaded.</p>
patch module "Subaru CAN Enhanced RAM Parameter Logging" loaded.</p>
patch module "Mitsu CAN RAM Parameter Logging" loaded.</p>
flashing tool "wrx02" loaded.</p>
flashing tool "wrx04" loaded.</p>
flashing tool "sti04" loaded.</p>
flashing tool "sti05" loaded.</p>
flashing tool "mitsukernel" loaded.</p>
flashing tool "mitsukernelocp" loaded.</p>
flashing tool "mitsubootloader" loaded.</p>
flashing tool "shbootmode" loaded.</p>
flashing tool "shaudmode" loaded.</p>
flashing tool "subarucan" loaded.</p>
flashing tool "mitsucan" loaded.</p>
1048576 byte image read.</p>
J2534 API Version: 04.04</p>
J2534 DLL Version: 1.00.3147 Sep 3 2010 00:11:07</p>
Device Firmware Version: 1.15.4474</p>
Device Serial Number: TAxr5rDT</p>
sending init sequence 1 (0001)</p>
sending init sequence 1 (0003)</p>
sending init sequence 1 (FFFF)</p>
no response to any known code</p>
interface close</p></body></html>
 

·
Registered
Joined
·
13 Posts
Did you read my how to? It will answer all you questions:
http://www.evolutionm.net/forums/la...s/705493-how-install-evo-x-ecu-na-lancer.html

If you are not able to flash your rom in the car, you must remove your ecu and do a bench flash. If you are not able to bench flash the evo x rom, you have to use an older EcuFlash version. The best Version to bench flash is Version 1.43. The newer version will only flash roms with the same first 4 digits. For example: If your car original rom ID is: 54410003, it will only flash rom IDs that's start with 5441... With the 1.43 Version, you can flash any rom into any ecu. Remember, when you do a bench flash, you must do it in recovery mode first and then flash it in normal mode.

See above...Could my ecu be locked?
 

·
Registered
Joined
·
13 Posts
Funny thing, got fed up and just turn the key and surprise, car started. a 2009 ECU with a 2010 vin, in a 2010 car, starting with a 2009 rom (53230006) and my rom is supposed to be 55180006... Ran like crap though (NA rom in there and I have a turbo in it)

But I cant flash (says that it cant write because of protected era), or bench it (see above)... I dont understand any of it.
 

·
Registered
Joined
·
158 Posts
It may be related to ECU Flash protected areas

Check

Open a text editor, copy below information, save, change file extension from .txt to .reg double click to merge into registry.

[HKEY_CURRENT_USER\Software\OpenECU\EcuFlash\flashing\mitsubishi]
"protect low memory areas"="false"

If this works, credit goes to UT_EvoX
 

·
Registered
Joined
·
13 Posts
It may be related to ECU Flash protected areas

Check

Open a text editor, copy below information, save, change file extension from .txt to .reg double click to merge into registry.

[HKEY_CURRENT_USER\Software\OpenECU\EcuFlash\flashing\mitsubishi]
"protect low memory areas"="false"

If this works, credit goes to UT_EvoX
I feel really dumb...Where do Isave this? I dont have a "flashing" folder inn my ecu flash folder...
 

·
Registered
Joined
·
13 Posts
I've tried 1.43.**** and no change. Earlier versions do not recongnise my tactrix cable...

But since the original rom works (somewhat)I am going to see if it will accept a 2009 evo x rom instead of my 2010 one... never know
 
21 - 40 of 46 Posts
Top