Mitsubishi Lancer Evolution Forum banner
1 - 16 of 16 Posts

· Registered
Joined
·
183 Posts
Discussion Starter · #1 · (Edited)
EDIT: went to the dealer and found improper PDI, rubber spring inserts were still in side which were removed!



Hi All X owners:

Has anyone noticed some weired clunky noises coming from, i believe steering wheel? when making turns at very slow speed? I am thinking the leather on steering wheel is rubbing on something??

Should i take it to the dealer?

Thanks
 

· Registered
Joined
·
126 Posts
Has anyone noticed some weired clunky noises coming from, i believe steering wheel? when making turns at very slow speed?
There's your problem, Evos aren't meant to be driven at "very slow speeds". ;)

Seriously though. My PT Cruiser had a similar problem a couple years ago. I left it alone for a while, but it got louder and louder. I finally took it in and it turned out the power steering hose had come loose from it's clamps and was actually rubbing on a moving part inside the engine. I'd take it to the dealer and have it checked out.

Dan
 

· Registered
Joined
·
10,012 Posts
yep take it to the dealer. keep us updated!
 

· Registered
Joined
·
183 Posts
Discussion Starter · #12 ·
hi guys!

I went to the dealer and they found that the rubber spring inserts were not removed due to the improper PDI.

Does anyone know if that could have cause any harm to my new car. Sucks on part of their service:mad:
 

· Registered
Joined
·
236 Posts
I had this problem once before, when the EVo-8 1st came out.
When they did the PDI, they forgot to remove the spring brace they call it.
My VIII drove like crap for a week. I knew the car should ride stiff, Being new to EVO
back in 2003, I think it was normal, Until we later found out they didn't remove that rubber insert, Use to reduce wear and tear on the struts when shipping and transporting.
 

· Registered
Joined
·
183 Posts
Discussion Starter · #16 ·
I had this problem once before, when the EVo-8 1st came out.
When they did the PDI, they forgot to remove the spring brace they call it.
My VIII drove like crap for a week. I knew the car should ride stiff, Being new to EVO
back in 2003, I think it was normal, Until we later found out they didn't remove that rubber insert, Use to reduce wear and tear on the struts when shipping and transporting.
thanks the car is alive again. On the other note The dealer need to get life if they don't even have time for doing a proper PDI. I got a documentaion of this and if any thing goes wrong related to this they are in trouble.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top