Mitsubishi Lancer Evolution Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I noticed black clouds from the back of the car under heavy acceleration a couple of days ago, and when I checked the oil its about almost an inch over the top hole.

I have been driving it hard for about 1500 miles. I understand overfilling the oil can cause pressure problems, and the owners manual even warns about it.

Anyone know the likely real world problems this may cause, either now or 10K, 30K, 50K miles down the road?

I am going to take it to the dealer tomorrow and give them hell, but I'd like to know if I should be pushing for extended warranties or for them to just sort it out and change the oil again.



Simon
 

·
Registered
Joined
·
1,077 Posts
I got the oil changed not too long ago too. I guess I'll check to see where it's at. I think you should go complain and see what you get out of them.
 

·
Registered
Joined
·
949 Posts
I wouldn't worry about it to be honest Dribbler. I would definitely give them a hard time, and maybe demand a free oil change or something, but the chances of any long term issues is pretty low.
 

·
Registered
Joined
·
11 Posts
I wouldnt worry about it. I remember one time they overfilled the oil on my rx8 and smoke was comming in through the AC vents lol...I went to the dealer pretty pissed. Let them check it out to be safe.
 

·
Registered
Joined
·
847 Posts
Dribbler, if it was oil coming out your exhaust it would be blue in hue.

The black smoke you're seeing is the sub-10:1 air/fuel ratios the car comes stock with. LoL.

On a more serious note, though, when you checked your oil, did you let the car sit long enough (about a minute) for the oil to settle in the pan? After letting it sit, you should take out the dipstick, wipe it off, stick it back in and pull it out to get a real reading of where your oil level is. If you check it right out after you stop the engine and don't give it a 'wipe off', the oil that sloshed around in the pan could make it look higher than it already is.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Update

So it went into the dealers today. It turns out there was gas in the oil- the mechanic had me sniffing the oil and it smelled strongly of it. He reckoned there was half a quart in there. Apparently short trips can cause this kind of thing, but mine drives 25 miles down back roads each day to work, do that wasn't the problem.

They changed the oil for free, updated the ECU again- I had already had the rough idle ECU flash, and also had one for hesitation at high (engine) speeds.

Hopefully that's the end of it- hope there isn't some general problem with these motors as several other people have reported smoke out the back too.
Simon
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top