Mitsubishi Lancer Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Has anybody had issues with an Evo x consuming coolant? Lately my car seems to use coolant with the level making it from the full to low line on the expansion tank in 500-1000, I've had to top it off three times but this is where things get strange, I've added a UV dye and over the past two weeks of very carefully examining everything no leaks were found anywhere. It's unlikely the cars burning it as there's no smoke and no coolant in the oil or vice versa, plus the head gasket and studs are less than a year old. Can somebody point me in the right direction?
 

·
Registered
Joined
·
2,127 Posts
Despite what you think, it's your head gasket. Especially if you've changed it. It's leaking into the motor, probably not at an alarming rate or else you'd see the tell tale signs but unfortunately coolant doesn't do magic on the side. It's going somewhere. I bet you a Coke it's disappearing into your cylinders.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
60 Posts
Just a thought, not sure if these systems are self burping but maybe there's just an air bubble working its way out. Notice and small spikes in temps occasionally?
 

·
Registered
Joined
·
1 Posts
So i have a 2015 Mitsubishi lancer and the coolant is running out fast and no signs of leaks or whatsoever and also the oil is black anyone can help me out on this?
 

·
Registered
Joined
·
890 Posts
So i have a 2015 Mitsubishi lancer and the coolant is running out fast and no signs of leaks or whatsoever and also the oil is black anyone can help me out on this?
You clearly have a leak somewhere. If your oil is black that means that the coolant isn't mixing with it, which is a good thing.
 

·
Registered
Joined
·
294 Posts
Could be a small crack somewhere, leaking cap, but you definitely have a tiny leak somewhere. Probably need to pressure test it and look for a small leak.
 

·
Registered
Joined
·
12 Posts
Not a good sign, i was burning coolant and was chasing it for awhile until i got a new block and problem solved. I think the coolant was mixing into the block oil channels and getting burned off. I feel for you bro i think i got PTSD from that shit.
 
1 - 11 of 11 Posts
Top