Mitsubishi Lancer Evolution Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
So I bought an hid kit for my 08 gsr from hidnation which I read after the fact is a shady low quality company. Anyway, I got the relay harness which was suppose to bypass the drl which it did, but when ever my drl would have been activated I could not turn the hid lights on and off. For example when I start my car up and the e-brake is engaged I can turn the lights on and off. As soon as I drop the e-brake I can't turn the lights on. Then if I turn the car off I'd be able to turn the lights on again. I triple checked all the connections and they were correct. This is when I read the reviews of hidnation and how half the time there products don't work at all. So I drive around for a week and then suddenly the lights won't turn on at all. I realize they sucked and removed everything including the relay harness. I put back the stock lights and now the drl and low beams still won't work. I checked the fuses already and they are good. Anyone have any ideas before I take it to the dealership?
 

·
Registered
Joined
·
53 Posts
Discussion Starter · #5 ·
I switched some relays around to see if that was the problem but the lights still didn't work. I don't think anything is disconnected cause after removing the aftermarket parts all I need to do is put the halogen bulbs back in the sockets and twist them into the housings.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top