Mitsubishi Lancer Evolution Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
Hey guys, I've been battling with this issue seemingly forever and at this point I'm just about ready to give up on the car completely. I was recently (within the last 6 months) tuned on an OMNI 4 bar map sensor as I'm boosting right around 37psi on an EFR 9174. The car runs great when it does run and pulls hard without hesitation. The car is not my daily driver so sometimes it will sit for a few days to a week without moving.

I'm having a consistent idle issue that results in the car starting up and idling for 1-2 seconds and dying right after. The idle holds at a steady 1500rpm when it starts up and just drops completely with no warning after 2 seconds. The only thing that I have been able to do to fix this issue is swap out the 4 bar with a new one but at this point the sensors are going out every week, and Ive been through over 5 sensors in under a 1000 miles of driving.

At this point I'm at a loss for what can be done, I'm pretty sure the tuner tuned the car for a 4 bar but I'm open to checking if that would be possible through evoscan, other than that I don't know what else to do, I've looked into the AEM sensors but they seem to not work with the stock ecu from what I've heard. Any advice at this point would be greatly appreciated, thanks in advance.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #4 ·
Are they sealing well in the manifold? Some people have to use the stock MAP sensor o-ring on the 4bar sensor.
I tried swapping the oem O-ring to the Omni 4 bar but the issue still persists. At the moment the only thing that fixes the car is swapping the 4 bar with a new one, and that only lasts a couple weeks if im lucky. Still looking for a solution to this problem its driving me crazy
 

·
Registered
Joined
·
1 Posts
MAP sensor isnt used at idle, MAF is used instead, i suspect its a bad tune as its runs well at WOT which is the easiest part of the tune while idling and cruising is the hardest!

are you able to take logs? if yes did you check your STFT, LTFT Idle?

What injectors are you using?
What Intake pipe are you using and how is the MAF sensor mounted?

Disregarding the tuner’s name, is he experienced in Evo X with big injectors (i presumed based on your turbo), big cams, omni 4 bar setup, if not i highly suggest you get it tuned by someone who is.
 

·
Administrator
Joined
·
3,388 Posts
MAP sensor isnt used at idle
Not necessarily. Both the MAP and the MAF calculate their own Load, and then the lowest of the two is selected. If the MAP is reading lower, it's used.
 
1 - 7 of 7 Posts
Top