Mitsubishi Lancer Evolution Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
954 Posts
Discussion Starter · #1 ·
So I've asked around, searched etc and cant seem to get a clear answer.

When tuning for flex fuel, and using the gas than pressure sensor signal return, it states in Tephra "we fool the EVAP canister so it doesn't give us trouble (codes etc).

Is that fooling done via a plug and play kit like Flexconvertor's kit? Or is this native to Tephra v3 software mod? I'm trying to figure this out and rather not buy a $400 plus kit that's "plug and play" that also includes fuel lines and other bits I don't need. All I need is the gauge and the sensor and the rest I can take care of.

I guess I'm saying that can I hardwire one in, and use the gas tank signal wire like the PnP kits and not have issues, or is there something else that needs to be done?

TIA
 

·
Premium Member
Joined
·
2,511 Posts
The fooling portion is done by both. You have to send a signal to the ECU so it can read the ethonal value and the evap system needs to stay happy or emmisions codes will pop.
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #3 ·
The fooling portion is done by both. You have to send a signal to the ECU so it can read the ethonal value and the evap system needs to stay happy or emmisions codes will pop.
And I get the sending a value portion. All the USDM kits I've seen that are plug and play utilize the 5v reference on the pressure sensor return as the Ethanol content sensor signal.
What I'm trying to figure out is if Tephra v3 is what keeps the Evap Canister happy via coding/tune, or if all that jazz is done via the plug and play kits. I'm led to believe its only done via tune/software in the ecu via Tephra, but I've never been able to get a concise answer. All I ever get is "idano I used the PnP kit"

Just curious how it all worked out before all the PnP kits came out if they all used the pressure sensor signal return as the E content sensor return.
 
Joined
·
5,215 Posts
You turn off the Evap CEL in the rom. You don't even need the Tephra ROM to do it.

Code:
[B]P0455[/B]

 Sometimes when "stealing" the Fuel Tank Pressure signal you will get a  P0455, to resolve this please using the following XML segments to up the  P0455 check 1594rpm to 7969rpm!

[B]59580004:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538bc" type="1D" scaling="RPMStatLimit"/> [B]59590005:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538bc" type="1D" scaling="RPMStatLimit"/> [B]52680022:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b4" type="1D" scaling="RPMStatLimit"/> [B]53610013:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/> [B]52690022:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b4" type="1D" scaling="RPMStatLimit"/> [B]55570006:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b6" type="1D" scaling="RPMStatLimit"/> [B]55580006:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b6" type="1D" scaling="RPMStatLimit"/> [B]56890013:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/> [B]58010005:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/> [B]58030005:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/>
More info: http://www.tephra.it/v3/
 

·
Registered
Joined
·
954 Posts
Discussion Starter · #5 ·
You turn off the Evap CEL in the rom. You don't even need the Tephra ROM to do it.

Code:
[B]P0455[/B]

 Sometimes when "stealing" the Fuel Tank Pressure signal you will get a  P0455, to resolve this please using the following XML segments to up the  P0455 check 1594rpm to 7969rpm!

[B]59580004:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538bc" type="1D" scaling="RPMStatLimit"/> [B]59590005:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538bc" type="1D" scaling="RPMStatLimit"/> [B]52680022:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b4" type="1D" scaling="RPMStatLimit"/> [B]53610013:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/> [B]52690022:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b4" type="1D" scaling="RPMStatLimit"/> [B]55570006:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b6" type="1D" scaling="RPMStatLimit"/> [B]55580006:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538b6" type="1D" scaling="RPMStatLimit"/> [B]56890013:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/> [B]58010005:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/> [B]58030005:[/B]<table name="P0455 Fix Minimum RPM (1594 -> 7969)" category="Misc" address="538ba" type="1D" scaling="RPMStatLimit"/>
More info: http://www.tephra.it/v3/
You will then need to connect the 5v analog output of the sensor to the ECU, at the moment we are hooking into the only "available" 5v input left on the ECU, this happens to be currently being used by the Fuel Tank Pressure sensor, which feeds into EVAP. Since we are overriding the pressure signal for flexfuel we send a fake signal to the EVAP system so that it doesn't complain. Using the diagrams below connect the 5v output from the ECA to the ECU


This was the statement I read on the Tephra site that made me question what the fake signal was sent from. But if its just modified values in the Rom/Cal then I'm good. That's the exact answer I was after, Thank You
 

·
Registered
Joined
·
4 Posts
Sorry to revive an old thread but I am having a bit of an issue with my diy flex setup just curious did the 5v tap in setup like stated above ^ leave the actual plug for the pressure sensor disconnected ? I've tapped into 5v and have the ecu reading ethanol with no codes just want to confirm I was right leaving pressure sensor unplugged ?

Thanks guys
 
1 - 6 of 6 Posts
Top