Mitsubishi Lancer Evolution Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter · #1 ·
Hi
Does anyone have the part number for the new fuel relay made in Italy please?

I believe it is black in colour with 'Made in Italy' stamped on it and supercedes the old black/green/blue ones!

Thanks
Mark

Also, the MFI relay part number if you have it! Thanks
 

·
Registered
Joined
·
1,138 Posts
It's MR122409, but only the new ones are made in Italy and Mitsubishi has fully replaced the blues up here in Canada with these. The older Omron batches with that same part number are all made in USA, so make sure before you buy. I've been using this relay for a few months now without any issues! Linked the pic :)

The Grey MFI relay is MR400709.

 

·
Registered
Joined
·
27 Posts
Discussion Starter · #4 ·
It's MR122409, but only the new ones are made in Italy and Mitsubishi has fully replaced the blues up here in Canada with these. The older Omron batches with that same part number are all made in USA, so make sure before you buy. I've been using this relay for a few months now without any issues! Linked the pic :)

The Grey MFI relay is MR400709.

Many thanks for the Info.
The MFI relay ( MR400709 ) is the same as I have but the new MR122409 I don't. The number 8627A024 is the relay ref I have and believe its for the blue one.
As I live in the UK I'm not sure if they will have the new part yet, I'll try tomorrow
Thanks again
 

·
Registered
Joined
·
1,138 Posts
So now there's a 4th version, and it's back to black? The blue Omron relays were made in Japan.
Yep, at least in Canada, there's a 4th version. I had a working Green one, but decided to get all Blues as someone of the other forums dissected the relays and found that the copper solenoid inside the blues were vertical and the beefiest. Long story short, perhaps due to QC issues with the relays or short supply from Japan due to earthquakes, Mitsu corporate has replaced all the blue relays with a Made in Italy black one that looks identical in size as far as I can tell.

Many thanks for the Info.
The MFI relay ( MR400709 ) is the same as I have but the new MR122409 I don't. The number 8627A024 is the relay ref I have and believe its for the blue one.
As I live in the UK I'm not sure if they will have the new part yet, I'll try tomorrow
Thanks again
No problem! Yeah, the 8627A024 was the number I went into a couple of dealerships with, but they all had a notice of change of part # to the black one. If they have the blue one in stock, I would still take that over the stock tiny black one!
 

·
Registered
Joined
·
1,138 Posts
Seriously? So what relays are available and the most reliable.
Blue's are still available online as well as at US dealerships that have them stoked up, but no longer available in Canada. Stock/Green/Blue have all at least failed once from what I've read but the highest frequency being the stock one. The Italy one is the only one that's yet to fail since I know of only myself and a couple other local guys using it. If you're paranoid, someone else mentioned that these should be swapped out with new ones as part of your regular maintenance no matter what color you get. Just for reference, I never had a problem with my stock, green, or the Italy one, but just to be on the safe side I've been changing them~
 

·
Registered
Joined
·
27 Posts
Discussion Starter · #8 · (Edited)
Strange one for me here Optiblue! ( Justin )

I ordered the fuel relay & the MFI relay from my local dealer ( Hereford, UK ) and the parts were showing available. Ive waited nearly 2 weeks so gave them a call, was told the fuel relay is in but the MFI relay is not ... has stopped being stocked ... and is no longer available to order!!!! The parts then tried to re-order on their computer but the part number has been closed and is now not available to order !!!!

Very strange but I am wondering if this is a problem mainly associated with you guys across the pond ( America / Canada ) as Mitsy Hereford say they have never replaced this part !!!

Happy I've got the fuel relay but bit confused re the MFI relay, I think I am correct in saying if the MFI relay stops working then the car won't start ... full stop! It is either working or not working, unlike the fuel relay which may not be working but the car will still work, just runs lean, then 'Bang' if you don't sort it out!

Think I should try to source an MFI relay from elsewhere ( SSP ? ) or just leave it ??

Thanks

Mark
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top