Mitsubishi Lancer Evolution Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,052 Posts
Discussion Starter #1 (Edited)
i did couple of WOT and when i came home i popped the hood to check if everything is ok... and i see this... not sure if its ok ... its lower pulley im not sure about... the other pulleys looks fine... let me know .. thanks...



Edit:same picture with red line is the pulley i'm talking about... doesn't it look off?? or is it fine??
 

Attachments

·
Registered
Joined
·
1,052 Posts
Discussion Starter #7
I checked after 1 hr of driving.. It's at the same spot.. After reading about pulley issue makes me nervous .. I don't have time to stop by dealership for about 2 weeks..
 

·
Registered
Joined
·
266 Posts
I posted the first thread on the pulley issue over at evom. The pulleys wear over the entire surface, but the problem like someone else pointed out is when they wear more on the outside and the belt begins to slip off for me.

So from my experience your pulleys don't have the same problem as I had. Although the only way to check forsure is to pull them off and inspect them.
 

·
Registered
Joined
·
1,052 Posts
Discussion Starter #17
I posted the first thread on the pulley issue over at evom. The pulleys wear over the entire surface, but the problem like someone else pointed out is when they wear more on the outside and the belt begins to slip off for me.

So from my experience your pulleys don't have the same problem as I had. Although the only way to check forsure is to pull them off and inspect them.
U think mine looks fine?
 
1 - 17 of 17 Posts
Top