Mitsubishi Lancer Evolution Forum banner

1 - 20 of 54 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter #1 (Edited)
My MR is 40,000KM and I went to the dealer ship to change the SST fluid but after 1,500KM i try to launch the car and i got this wierd cool down.(before with the factory SST fluid its was working fine and launch the car like 40 times without problem)

Here a video when a do a launch and I stay the gaz pedal to the floor.

Sorry about the bad video since its hard to drive and film at the same time ;)

Should i go back to the dealership and explain the situtaion of I must do something else?

Thanks for your help :)
 

·
Registered
Joined
·
1,582 Posts
Yes dont mess with it, go to the dealership, dont mess around with the SST and trying to figure it out yourself, unless you have upgaded it already.

It sounds like somthing stupid do to the fact , when it started happening. if you can remove the tune i would do that before going in.
 

·
Registered
Joined
·
174 Posts
Discussion Starter #3
Yes dont mess with it, go to the dealership, dont mess around with the SST and trying to figure it out yourself, unless you have upgaded it already.

It sounds like somthing stupid do to the fact , when it started happening. if you can remove the tune i would do that before going in.
I will put back the original setting in it and go back to the dealership.
 

·
Registered
Joined
·
1,582 Posts
true,but if something is wrong then its better to fix it then to go "ok lets just not play with it" i love the launch control, best part to the SST
 

·
Registered
Joined
·
174 Posts
Discussion Starter #7
The few times I've tried to launch my car it gave me those messages too! Are you sure you're holding the brake and mashing the gas?
Last summer I launch the car a few times without problem.
And yes I put both pedal to the firewall ;)
 

·
Registered
Joined
·
6,110 Posts
true,but if something is wrong then its better to fix it then to go "ok lets just not play with it" i love the launch control, best part to the SST
I agree 100%. The issue is that even with all SSP's hard work, they still don't fully grasp the inner workings. So say he breaks something internal which isn't a clutch or electronics-body, he's up chocolate creek without a popsicle stick. Then it'd be the long sad story of parts hunting and Mitsu voiding warranties, etc.
 

·
Registered
Joined
·
13,446 Posts
What is that supposed to mean???
Dont use that LControl.....Nissan admitted that they can use that LC and how to do it(they even modify it to do 2.8sec/60) while Evo X noh....I mean it is not really an approved function by Mitshubishi to do that.
 

·
Registered
Joined
·
6,110 Posts
Dont use that LControl.....Nissan admitted that they can use that LC and how to do it(they even modify it to do 2.8sec/60) while Evo X noh....I mean it is not really an approved function by Mitshubishi to do that.
I know about the launch control. Just saying that launching 20+ times and something is going to break, and when it does it'll be expensive since officially the unit is serviced as a whole.
 

·
Registered
Joined
·
678 Posts
Same thing is happening to me. I used LC 25 times last season and now I get the slow down light even when the engines cool. Wondering if it has something to do with the AWC reflash I had done when I was at the dealer last.
 

·
Registered
Joined
·
174 Posts
Discussion Starter #14
I went back to the dealership and they added 220ml of tranny fluid.

Now the tranny is shifting a lot smoother. I will do around 500km before retrying the launch control.
 

·
Registered
Joined
·
1,582 Posts
I went back to the dealership and they added 220ml of tranny fluid.

Now the tranny is shifting a lot smoother. I will do around 500km before retrying the launch control.
Reply back to use when you do the LC I am really curious to see if that was it. I love the 1/4 mile and thats a hugh heads up when at the track.:+1:
 

·
Registered
Joined
·
174 Posts
Discussion Starter #18
WTF? they didn't fill it up the first time?
The problem is there no dip stick for the tranny on the SST :(
So its hard to knows how much they need to put in.

They explain to me, they have to follow a chart and normally this work fine.
 

·
Registered
Joined
·
678 Posts
I went back to the dealership and they added 220ml of tranny fluid.

Now the tranny is shifting a lot smoother. I will do around 500km before retrying the launch control.
There is no reason to wait 500kms to use the LC. Go test it now and report back.

Cheers
 
1 - 20 of 54 Posts
Top