Mitsubishi Lancer Evolution Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
393 Posts
Discussion Starter · #1 ·
My car is at 15,000 miles now. I rarely launch it from 0, but ounce in a while I do a rolling launch from low speeds. 2 days ago, I try to do a rolling launch from around 15-20mph, and when I let go of the clutch at 5000RPM the car didnt move, while the engine was still revving high.

After that I went back home with no problem but obviously there was a very strong burning smell. The problem is that the next day, and the day after that, the same smell starts to occur (not as strong) even though Im driving normaly. Although I cant feel any slipping.

Is my clutch ok? can I still drive it hard for a while?
 

·
Registered
Joined
·
6,195 Posts
Just drive it normal for a few days to unglaze the disk.
 

·
Registered
Joined
·
3,470 Posts
are you on the stock clutch and wondering why it might slip on launch with 375whp?
 

·
Premium Member
Joined
·
1,036 Posts
With that much TQ you are on borrowed time on the stock clutch that's all that is to it.

Just drive it nicely for the next week or so and see if the smell goes away. Although with that much power you should really be planning on replacing the clutch at some point. Start pinching pennies now if you need to.

A way to test if the clutch is holding is to be rolling in third gear at about 2500RPM or so and then put the power pedal down all the way. Once boost hits and peak TQ it will either hold or slip. If it slips time to get a clutch in the works.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top