Mitsubishi Lancer Evolution Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1,206 Posts
Discussion Starter · #1 ·
so today when i arrived at my destination, i was sorting through my phone when my idle became rough again. usually, the car would correct itself out and after a couple of seconds, it would go back to normal. not today however. after couple of ups and downs, the car actually stalled on me. the steering wheel was turned to the left, maybe half-way.

anybody have experience with this? what causes the rough idle in the first place and why did it finally die on me today?

the car has 60k miles with intake, tp, uicp, and 3" exhaust. it can't be the tune because i've had this crappy idle since the day i purchased it.
 

·
Registered
Joined
·
3,470 Posts
What kind of intake do you have? is it shielded from the fan? Also, hollywoodX had a thread a while ago about some more sinister possible causes of this issue, you can probably search for it.
 

·
aka MitsuEvoX
Joined
·
1,000 Posts
+1 Hollywood's thread was about mivec fluctuations. I didn't read all of it, though I probably should
 

·
Registered
Joined
·
1,206 Posts
Discussion Starter · #4 ·
What kind of intake do you have? is it shielded from the fan? Also, hollywoodX had a thread a while ago about some more sinister possible causes of this issue, you can probably search for it.
aem with top off.

even during 100+ weathers my car never stalled. today was like 65 and it stalls...
 

·
Registered
Joined
·
8,999 Posts
FPR hose is good. its been zip-tied since 5k miles.
So found this thread you posted; http://www.evoxforums.com/forums/showthread.php?t=58274

at wot, my fuel cuts-off between 4k-5k rpm range

Reading that and looking at this I would say your issues have been a ton of detention and now bearing damage. Since I can't find where you have been tuned or that you can log I will assume you don't know you've been knocking. That feeling you were getting of traction slipping is timing cut due to learned knock. The idle is trashed now because you have no oil pressure to keep the exhaust MIVEC gear advanced and it's dipping down into the -35* range.

I suggest you pull your oil pan and run it through a filter and a clean dish to inspect it.
 

·
Registered
Joined
·
1,206 Posts
Discussion Starter · #8 ·
So found this thread you posted; http://www.evoxforums.com/forums/showthread.php?t=58274

at wot, my fuel cuts-off between 4k-5k rpm range

Reading that and looking at this I would say your issues have been a ton of detention and now bearing damage. Since I can't find where you have been tuned or that you can log I will assume you don't know you've been knocking. That feeling you were getting of traction slipping is timing cut due to learned knock. The idle is trashed now because you have no oil pressure to keep the exhaust MIVEC gear advanced and it's dipping down into the -35* range.

I suggest you pull your oil pan and run it through a filter and a clean dish to inspect it.
but the car is driving fine. idle was acting up just that time. shouldn't the idle be crap all the time?

what am i looking for? metal shavings?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top