Mitsubishi Lancer Evolution Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
I'm having a pickle of a time trying to figure out this leaning issue that happens at higher RPM's. Its like the AFR's casually get leaner as the RPM climbs. I've replaced the Fuel Relay from the blue one to the newer black one and that didn't make a difference, theres no obvious signs of an exhaust leak from what I can tell. Any ideas as to what may be going on here?
 

Attachments

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Fuel filter? Fuel pump? Have you checked or logged your FP during a WOT run?
I don't have a fuel filter aside from the mesh piece in the return line in the pump housing, which I checked and cleared. I wasn't aware that you can log the FP in EvoScan though:duh:, you wouldn't happen to have the definition would you? I can't find any information on how to log that lol
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
I want to test to see if its the fuel pump sh*ting the bed, anybody know if hot-wiring the pump for 12v is a good way to test it out?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
E85?

Looks like the pump not being able to keep up to me.

What pump?
Believe it or not, stock pump on 93. Basic bolt ons with stock turbo and stock injectors.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #8
What are your IDC's?
The max I see is 100% using the (2ByteRPM*IPW) / 1200 calculation. I've heard before that 100% on Evoscan is 80% on injectors, but I'm not sure if thats true or not.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #10
yea I would say your pump is done. Time to upgrade.
Sweet. I was getting antsy, need to mod something. I was tuned by CBRD with a consistent 11.5 AFR, do you think throwing in a Walbro 255 would constitute a retune or should I replace the OEM pump?
 

·
Registered
Joined
·
25 Posts
Discussion Starter #12
what are your current fuel trims? Are fuel trims turned off for WOT operation?

Have you logged fuel trim in use during WOT?
LTFT is at 4.6875 and all 0's throughout WOT.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #13
what are your current fuel trims? Are fuel trims turned off for WOT operation?

Have you logged fuel trim in use during WOT?
I have 4 datalogs in a zip in the original post if that helps :D
 

·
Registered
Joined
·
25 Posts
Discussion Starter #15
Okay, yea still leaning towards the pump being done. How many miles?
2008 @ 39,500 It's definitely concerning, especially because it pegs 13:1 at WOT lol
 

·
Registered
Joined
·
25 Posts
Discussion Starter #16
Anybody know if a drop in DW65c constitutes a retune? MAP has a 10% sale that ends today!
 

·
Registered
Joined
·
1,378 Posts
It would increase FP possibly, making the AF mix richer. Shouldn't be a problem IMO. Just watch the AF, to make sure it's reasonable but I doubt you'll see much of a change at all.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #18
Just an update. I replaced the fuel sock, cleaned out the pump housing and just started running injector cleaner which nearly fixed the issue. I'm going to run a full tank of it then run another set of logs. But take a look at the difference.
 

Attachments

1 - 18 of 18 Posts
Top