Mitsubishi Lancer Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hey so i need some help. I bought my evo used, 1 owner. 2015 gsr with 26,000 miles. Yesterday I was taking my wastegate actuator out and i noticed a missing bolt. it is right on the compressor side of the turbo and there is a bracket that extends out from it. No bolt in there. Does someone know if this is supposed to be like that or what. also if a bolt is supposed to be there does anyone know the part number for it. in the pic you can see the stock intake tube going into the turbo.
 

Attachments

·
Registered
Joined
·
30 Posts
Yes there’s supposed to be a bolt there. If I remember correctly it’s one of the bolts that hold the turbo to the motor. I think it’s a M10x1.25 bolt. Could be wrong though.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #3
Yes there’s supposed to be a bolt there. If I remember correctly it’s one of the bolts that hold the turbo to the motor. I think it’s a M10x1.25 bolt. Could be wrong though.
Thank you for the response. unfotunately i have found many missing bolts, parts on this car because the previous owner had no idea what they were doing. Ive been correcting everything that he did wrong for the last 8 months. If anyone knows the exact specs for this bolt please let me know. I want to get a bolt in there asap
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
UPDATE : I purchased a M10x1.25 30MM bolt and it fit perfect. Turbo support bracket is now properly bolted up. Thanks for the responses.
 
1 - 6 of 6 Posts
Top