Mitsubishi Lancer Evolution Forum banner

41 - 60 of 64 Posts

·
Registered
Joined
·
675 Posts
I was having a problem with this relay working intermittently when I first got the car. I just pulled the relay and jumped terminals 30 and 87. Haven't had a problem since, and that was about 10,000 miles ago.

Some people worry about the pump and fuel getting too hot running full voltage all the time, but as long as you aren't running the tnak nearly empty for long periods of time i doubt there will be any problems with overheating of the fuel or pump. Heck on the supras we run twin walbro 255s at full voltage all the time and never have any problems with them.

-Darin
Makes sense to me, may just do this for peace of mind....
 

·
Registered
Joined
·
112 Posts
Hi I'm new to this forum and not a gear head to say the least, but with this problem, is it for newer models or older ones? I have a 2011 evo X mr touring edition.
 

·
Registered
Joined
·
5,820 Posts
If you live in a cold climate it's a good idea to get the upgraded relay. If not you'll be fine. The zip-tieing everything, that affects all years.
 

·
Registered
Joined
·
5,820 Posts
the 2011's and 2012's still have the shitty black relays, so get the new ones
Huh? Nah. So there were shitty black relays in the 2008s. Then they put in green relays in 2010's. Then they put some green in the 2011's and non-shitty black relays in some 2011's and all 2012s. Least that is my understanding.
 

·
Registered
Joined
·
306 Posts
I should do this before winter rolls around. what should I replace the black ones with? I saw earlier to replace it with another black one that doesn't make much sense to me.. Anyone want to.clear this up

Sent from my SGH-T769 using AutoGuide.com App
 

·
Registered
Joined
·
5,820 Posts
Read this an decide for yourself.

http://www.evoxforums.com/forums/showthread.php?t=58941

The new good relays are black ones. Whether or not you have good black ones or bad black ones, I don't know, but the ones they are selling you are manufactured by mitsu. So chances are you could have one, I don't know.
 

·
Registered
Joined
·
7 Posts
Okay so while launching my Vo last night [08 GSR] it usually two steps around 5800rpms. No two step!? Launched around 5500 traction off and it came out of the hole hard but then fell on its face, backfired, picked up boost and was fine the rest of the time. It only did it in 1st gear. Then it did it again with a big backfire just punchin in it 1st. Ive been thinking fuel delivery air fuel ratio? Exhaust leak? Ecu? Ignition timing retard!? I know alot of us has that horendous ignition timing retard insufficient code so often and is usually just ignored but are these actual symptoms!? Help!:wtfsign:
 

·
aka 1990ggsxnj
Joined
·
933 Posts
Okay so while launching my Vo last night [08 GSR] it usually two steps around 5800rpms. No two step!? Launched around 5500 traction off and it came out of the hole hard but then fell on its face, backfired, picked up boost and was fine the rest of the time. It only did it in 1st gear. Then it did it again with a big backfire just punchin in it 1st. Ive been thinking fuel delivery air fuel ratio? Exhaust leak? Ecu? Ignition timing retard!? I know alot of us has that horendous ignition timing retard insufficient code so often and is usually just ignored but are these actual symptoms!? Help!:wtfsign:
Thread for this issue started here.
 

·
Registered
Joined
·
33 Posts
We went with a external fuel system for my build:

ID-1300 Injectors
Integrated Engineering Surge Tank
Bosch 044 Fuel Pump
Walbro 255 Fuel Pump (In Factory tank)
Cosworth Fuel Rail

Definitely by passes any fuel fails and it has an interesting extra sound from outside the car as well.

Car was just tuned this past weekend.

MR SST (Dodson clutches) and FP Red Turbo. Loving it!
 

·
[Global Mod], [Local Team Member]
Joined
·
2,511 Posts
Just finished my fuel system.
radium auto everything. FPR/fuel rail. -6 lines all up and down car. Hard wired walbro 400 e85. Id1300s are last
 

·
Registered
Joined
·
6 Posts
Anybody experiencing any late start ups on a stock set up? Just recently bought my 2014 GSR and I've been experiencing what I think can be a fuel issue. I already upgraded to the OEM "green" fuel pump relay even tho I already had a green one in its place when I bought the car. I decide to work my way from the cheapest expensive first. I'm still experiencing late start ups, I plan on checking fuel pressure, I'm also planning on upgrading to a bigger fuel pump for e85 but I wanted to see if my stock pump may have been a faulty one.
 

·
Registered
Joined
·
29 Posts
My last Evo had the fuel line chewed by a rodent and a mile from my house, taking off very mildly from a red light I noticed giant flames shooting out of my hood vents, burned down from the firewall forward- thank you local FD! This was years ago but seems like yesterday. Now it's all stainless all the time, no issues.
 
41 - 60 of 64 Posts
Top