Mitsubishi Lancer Evolution Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi everyone, I wanna to ask regarding my evo x , can start engine but put on D , it’s doesn’t move, is there are gearbox problem ? Or setting problem ? Please help if know, many thanks .
 

·
Registered
Joined
·
3 Posts
Sometimes it can be the clutch baskets burnt and fused together, Sometimes it can be oil starvation from the internal oil filter not being changed. Sometimes it can be from not changing the sst oil every 15k Sometimes it can be from boosting on cold sst oil. Sometimes it can be the soleniods on the mechatronic. Sometimes it can be the internal clutch seals. Check the sst manual and sst dtc values with evoscan software and openport2 cable. Then if the dtc is not mechatronic related, then Take the sst trans out and send it to Kozmic, or to Dodson in Auckland if you are in NZ.
 

·
Registered
Joined
·
4 Posts
Hi everyone, I wanna to ask regarding my evo x , can start engine but put on D , it’s doesn’t move, is there are gearbox problem ? Or setting problem ? Please help if know, many thanks .
Could be a couple things brake pedal sensor. Sometimes depending it’s on a uphill you really gotta mash that thing down to get it out of park. If that doesn’t work it’s most likely a sensor connected to brake pedal can you get it to reverse or is it stuck in park??
 

·
Registered
Joined
·
23 Posts

·
Registered
Joined
·
179 Posts
Hi everyone, I wanna to ask regarding my evo x , can start engine but put on D , it’s doesn’t move, is there are gearbox problem ? Or setting problem ? Please help if know, many thanks .
Can you tell as about history of this car when its started any accidents any work on the car... could be as simple as a plag not completely connected in a plug...I had same issue when I bought 2015 with a left rear door damage from the auction and car would start but would not drive and with only 20k miles on the car... My brother in law is very good with finding and fixing electric and computer problems in the car, that his job, he has 2 shops, and he found out what was wrong with mine...In my case it was someone went into the computer and instead of 0 typed O and its in a vin number and computer would not recognized it and was not working in my case...But it blow my mind why someone would do that purposely?
 
1 - 8 of 8 Posts
Top