Mitsubishi Lancer Evolution Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hi everyone! I am new and this is my first post on this forum.

I own a 2010 Lancer Evo X GSR with 110k. I bought it recently about 2 months ago from a used car dealer. The car runs and drives well, but since I have owned it I have been noticing the clutch and shifting between gears doesn't feel smooth. The clutch pedal itself is a lot harder than normal to press down. The car engages each gear (and does not slip out), but in-between, it will usually click and lightly/moderately grind. Sometimes when I engage into another gear, the car will kind of lightly jerk back and forth a bit.

With this, I have noticed this car has barely any torque to it. It feels like 25% torque of what it should be. I have personally driven another bone-stock Evo X like mine and also an Evo VIII, and those two cars felt very different in terms of their torque pull. It feels like when I drive my car, I am driving a naturally-aspirated vehicle or something. I thought it was related to my turbo system and had a boost test done. I fixed the found leaks, and there was no change to the torque pull.

I am in a pickle and not sure what these issues could be. I am wondering if both the clutch issues and lack of torque could be one culprit itself? There was no record of when the last time this car had its clutch & flywheel replaced. The recalled Clutch Master Cylinder was already done. I took it to my local Mitsubishi dealer and they said everything seemed fine/safe to drive. However, I am still experiencing these problems. The technicians thought maybe it could be an aftermarket clutch installed and that is why? They recommended a transmission fluid change which I just did with OEM fluids correctly, but it didn't really do too much.

~Any insight appreciated, thanks!
 

·
Registered
Joined
·
205 Posts
Besides you, anyone else drive your EVO with the same issues?
My twin clutch had a hard clutch pedal.
Lol maybe you lucked out and you could of bought a built EVO??

If I was you I’d go to a reputable EVO shop near you and tell them to check everything and then get a safe tune.
 

·
Registered
Joined
·
274 Posts
Yea the clutch could just be a stiffer one and that's why the pedal feels tougher..

As far as the "pull", does the rpm's raise really quick like the wheels are spinning and drop back down? Like the clutch is slipping?

Maybe it is just no where near as fast as you want it? The X 5-speed is not smooth and you will feel a slight grind sometimes. But swapping the fluid will probably help. I would replace all the fluids.. The trans, transfer case, rear diff, AYC..

But yea take it to a Evo shop and see what they say. Maybe there is something wrong with the turbo.
 

·
Registered
Joined
·
23 Posts
Could be an upgraded clutch... maybe a 6 puck clutch. Those types of clutches do get grindy and make the clutch pedal feel stiffer.

As for the "torque" issue, check to see if the clutch pill is still in the clutch line. That might be causing the car to feel like it's not pulling hard because it's slipping the clutch for you.
 
1 - 4 of 4 Posts
Top