Mitsubishi Lancer Evolution Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hey guys thanks for taking time to look at this.

ID1000 injectors, walbro pump, BBX Lite turbo, CBRD Tubular, AMS fuel rail, ETS Intake, fmic, upper and lower pipes, CNT exhaust, CNT catted downpipe.

all tuned

After getting the above installed and tuned I have been experiencing occasional / often erratic idle while @ stop.

It doesn’t happen all time but normally occurs when I am at full stop (e.g. traffic lights). The revs bounce all over the place from 800rpm down to 200rpm and sometimes causes the car to stall.

When I see this erratic idle about to happen, I normally give the car a bit of gas to prevent the stall (and embarrassment!). The plugs have been checked and my tuner switched out my relay to the blue one.

Recently I have been monitoring my A/F gauge and noticed that the erratic idle is normally accompanied by very lean readings (e.g. 17+ or “****” on the AEM gauge). When my A/F is 15 +/- the idle is perfect.

I've taken it back to my tuner but they can't get the problem to replicate. A little bit of daily driving in the car and it should happen @ least once but they couldn't get it to happen. Has anyone experienced this problem? Below are some videos of the cars idle jumping around. Within a 1 mile radius my car managed to stall out and show signs of erratic idle with strong sputtering from the engine during the erratic idle. Turn up the volume or wear a head set to hear the idle chirp.

[EDIT NOTE] I had ETS Intake, FMIC + U/L pipes and the CNT downpipe + exhaust before the tune and I never had this problem. So I don't think its from the fan turning on throwing hot air into the intake. Plus I have the heat shield on.

Never did I once accidentally hit the gas pedal turning filming, this was all within a 1 mile radius (about 3 minute drive time) at the jack in the box and sitting on front my house.

This was @ a stop in jack in the box drive thru. Notice car's idle jumps @ the very beginning followed by the car completely cutting off wth?

HTML:
http://www.youtube.com/watch?v=ySczP33DWRo
This is the most common type of erratic idle I get however its usually more drastic dipping down to the 500's. This was a minor one and what I managed to capture on film.

HTML:
http://www.youtube.com/watch?v=4wia68Putv8
Notice how the idle jumps up by itself. Also notice the AFR gauge.

HTML:
http://www.youtube.com/watch?v=WfalI4Sgk5w
 

·
Registered
Joined
·
801 Posts
Is your fuel pretty low when this is happening or is it happening with a full tank too?
 

·
Registered
Joined
·
2,657 Posts
assuming no leaks.. (including exhaust)

it will be an injector or intake issue.

either the intake you have isn't proving a nice laminar flow of air to the MAF.

or the injectors need to be dialled in a bit better..

do you have logs?
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
assuming no leaks.. (including exhaust)

it will be an injector or intake issue.

either the intake you have isn't proving a nice laminar flow of air to the MAF.

or the injectors need to be dialled in a bit better..

do you have logs?
I do not have logs I'm trying to get a hold of a AP so I can get some #'s for the folks helping me with this problem. I appreciate the help
 

·
Registered
Joined
·
5,820 Posts
I had some idle fluctuation then I found a hole in the coupler for my intake right before my MAF, have you checked your couplers?
 

·
Registered
Joined
·
1,014 Posts
I have the same thing happen with the same injectors as you. Golden did something that helped it out but I couldn't tell you what. My idle was a lot worse than yours though and at times is still a little jumpy.

Edit: NM I have DWs...misread. But maybe it could still be the same issue.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #9 ·
The hose is zip tied on there I'll take a look at my couplers. They're less than a year old but hey could be torn.
 

·
Registered
Joined
·
6,195 Posts
assuming no leaks.. (including exhaust)

it will be an injector or intake issue.

either the intake you have isn't proving a nice laminar flow of air to the MAF.

or the injectors need to be dialled in a bit better..

do you have logs?
x2
 
1 - 10 of 10 Posts
Top