Mitsubishi Lancer Evolution Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Need help guys. Evo x yesterday when I was in 4th gear went wide open throttle and at around 5krpm it's cutting the throttle body and limiting air flow/boost pressure but when you back off to 95% it resumes like normal any ideas? Also had it at the tuners today its nothing within the tune he says he even disabled at the limitations and overboost. No check engine light or error codes. Mods are id1300, walbro 450 fp, radium fuel hangar and fuel rail, full e85, grimspeed 3 port boost controller, turbosmart bov, intake, Megan turbo o2 housing, invidia turbo back, garret gtx3071r gen 2
 

· Registered
2017 Audi RS3 Stage 2 Unitronic Tune 93 Octane
Joined
·
1,972 Posts
I’m surprised the tuner didn’t have a solution to the problem. Spark plugs? Clogged injector.
No impact, no idea. You will have to do a pull and send in a log to the tuner. See what’s failing.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
I’m surprised the tuner didn’t have a solution to the problem. Spark plugs? Clogged injector.
No impact, no idea. You will have to do a pull and send in a log to the tuner. See what’s failing.
This all was trying to be solved during the tune revision. Injectors less the 1k miles spark appears to be fine
 

· Registered
Joined
·
20 Posts
How much fuel was in the tank? I get the same issue but only when it's around a half tank or less. Only in 4th, only when wot, usually back to back pulls. I also have a 450 and id1300s. I always assumed it was fuel starvation because it doesn't happen on a full tank.
 

· Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
How much fuel was in the tank? I get the same issue but only when it's around a half tank or less. Only in 4th, only when wot, usually back to back pulls. I also have a 450 and id1300s. I always assumed it was fuel starvation because it doesn't happen on a full tank.
It was almost a full tank. Further testing the gear doesn't matter as much I got it to do it in 1st and 5th now. I'm starting to believe my tune is not correct or it's a fueling issue putting the throttle into a safety mode I honestly don't know
 

· Registered
Joined
·
6 Posts
fuel cut? check the bypass to be made to all evo x in regards to the fuel pump housing.. i think your return line is clogged, you got afr? same thjing happened to me and my mechanic did some modifications the fuel housing..
 

· Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
fuel cut? check the bypass to be made to all evo x in regards to the fuel pump housing.. i think your return line is clogged, you got afr? same thjing happened to me and my mechanic did some modifications the fuel housing..
I'm going to upgrade the fuel line next. I do have a afr installed. I don't think it's the housing because it's a new radium sending unit
 
1 - 8 of 8 Posts
Top