Mitsubishi Lancer Evolution Forum banner
1 - 20 of 26 Posts

·
Registered
Joined
·
905 Posts
Discussion Starter · #1 ·
So I finally got my boost gauge in, and I'm wondering what normal range is?

Right now I sit at -20 at idle and at WOT I hit 19. I'm a little concerned about my WOT number, but I'm getting Clipse tuned so I'll let the pro do his thing.

What do you guys see for numbers?
 

·
Cunning Linguist
Joined
·
12,363 Posts
-20 at idle? 19 at WOT?

I'm not an expert, so take what I say with a big grain of salt (oxymoron much?), but that doesn't seem right. Possible boost leak?
 

·
Cunning Linguist
Joined
·
12,363 Posts
-20 is ok because its just vacuum, mine sits at -18 at idle or some where around there. 19 at WOT is really low though, so yes check all hoses like Eyler said
I've never gotten that low on my wideband...I sit at like -10 to -12 I think.
 

·
Cunning Linguist
Joined
·
12,363 Posts
Might be my tune.

But, at 19 psi at WOT we could be several things, boost taper due to the stock wastegate or BOV leaking, a boost leak, a faulty boost gauge...

So many factors, and I'm not going to give a straight answer because I'm not smart enough.
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #9 ·
Yea, I'm wondering about the low 19 psi.
 

·
Registered
Joined
·
109 Posts
Yea, I'm wondering about the low 19 psi.
It depends on a few variables. If you're seeing 19 psi between 4000-5000 RPMs you might have a boost leak. If you're seeing 19 psi at redline that isn't really anything to be worried about.
 

·
Registered
Joined
·
440 Posts
I too get -19 -20 at idle, but was spiking 25-26 at WOT.
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #14 ·
Well I must have a boost leak......

Boost is at -20 at idle and 13 peak with it settling at 10 psi.

Checking my lines.......
 

·
Registered
Joined
·
14,174 Posts
*Head Slap*

It's not -20 PSI. It's -20 In.Hg... Which is like "-10 to -12" PSI (Doesnt exist because PSI can't describe a vacuum state)

if you're stock 19 is fine.
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #16 ·
*Head Slap*

It's not -20 PSI. It's -20 In.Hg... Which is like "-10 to -12" PSI (Doesnt exist because PSI can't describe a vacuum state)

if you're stock 19 is fine.
My stock 19 has become 13.
 

·
Registered
Joined
·
14,174 Posts
Yeep. That's a boost leak it seems... Check the lines to the boost gauge itself... Does the car feel different?

Do you have an Accessport?
 

·
Registered
Joined
·
905 Posts
Discussion Starter · #18 ·
Tactrix and Evoscan. I have, everything looks secure. I might change out the stock BOV for my Synapse and see if that changes.
 

·
Registered
Joined
·
14,174 Posts
Can you run a log and see what the ECU is reading?
 
1 - 20 of 26 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top