Mitsubishi Lancer Evolution Forum banner

1 - 8 of 8 Posts

·
Registered
2014 Mitsubishi Lancer Evolution GSR
Joined
·
5 Posts
Discussion Starter #1
Bought this car used and everything on it as far as I know is stock except for the brakes which I've redone and the sound system. I have the clutch replaced immediately upon buying it because the last person burnt it out of existence. We're talkin like this thing had ash coming off of one side and on the concave side of the flywheel there was three different 2 inch wide heat spots on there and all the teeth for pretty much ground out of existence. The guy drove this thing like he was learning to drive clutch. Got that fixed and now I have a new issue and I don't know what it is.

I start accelerating it revs up by a 1000~ RPMs drops off and then accelerates. No I'm not flooring it. I went as far as to drive the gas pedal with a stick (yes from a tree) to make sure that I had the same pressure. I think in the video I pushed it about an inch while in 5th. Also happens in other gears.

Video is uploaded to discord.


2014 Mitsubishi Lancer GSR
 

·
Registered
Joined
·
7,787 Posts
From your descrition, your clutch is slipping. Stop driving it before you do more damage.
 

·
Registered
2014 Mitsubishi Lancer Evolution GSR
Joined
·
5 Posts
Discussion Starter #3
Stop driving it

I don't really have a choice but to drive it because it's my only way I can get to work. It's either I drive it to work or I have it in the shop.

After driving it around a little bit and actually focusing on Strictly just the clutch it doesn't slip in first or second. Also when a clutch is either burning or going there is a very distinct rotten egg smell that isn't present. Also last time I replace the clutch when it was going I lost pretty extreme gas mileage which is also not happening. Currently I'm sitting at 21.6 MPG after driving it 15 miles. Last time I replaced it I was getting at best 12 to 13.
 

·
Registered
2014 Mitsubishi Lancer Evolution GSR
Joined
·
5 Posts
Discussion Starter #8 (Edited)
Rather than the clutch being worn out I believe it's outright defective. Engine speed increases without actually accelerating while at Full Throttle. Used this video for reference.

EDIT: Thursday I go to get it looked at.

 
1 - 8 of 8 Posts
Top