Mitsubishi Lancer Evolution Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
My EVO is 2008 EVO X GSR
Only add K&N intake system and Accessport Stage 1 tuning!

I found there is a little oil leak at the back of engine gasket,
close to turbo side!!
Could anyone help me take look of it?!
Is that a problem?!
Thank you for the help!!:bowlol:
 

Attachments

·
Registered
Joined
·
3,470 Posts
Could you point out where exactly the leak is? from the pix, I'd guess a leaky valve cover gasket, which is not too difficult to remedy.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
Thank you sir!!
I don't see lots oil, but it looks like been there for a while build up!!
I am wondering, is that because I put too much engine oil, or because the engine has too much pressure?!

Thanks again!!:bowlol:
 

Attachments

·
Registered
Joined
·
118 Posts
check the integrity of the rocker cover gasket. or maybe just not tightened down enough or the bolts don't have the right washers.
 

·
Registered
Joined
·
8,771 Posts
Valve cover... I have an '08 and replaced my valve cover 3 times, not one leak.
 

·
Registered
Joined
·
3,470 Posts
just looked at the pic with the arrows. I don't think you have any issue. Looks more like normal under-hood grime mixed with a minimal amount of oil that seeps through that gasket over time. No biggie. Clean it up and check it again in a week or two. If it's still clean, you're good.
 

·
Registered
Joined
·
1,052 Posts
just looked at the pic with the arrows. I don't think you have any issue. Looks more like normal under-hood grime mixed with a minimal amount of oil that seeps through that gasket over time. No biggie. Clean it up and check it again in a week or two. If it's still clean, you're good.
I just checked mine.. It looks same as urs and I think it's normal..
 

·
Registered
Joined
·
8,771 Posts
I have only ever cleaned my engine bay 2 or 3 times in 3 years and I have NEVER had grime/oil/grease or anything anywhere around my valve covers. Come to think of it, I have never had it on any car I have owned except for the one time I had one with a leaking gasket.

OP, clean under your hood and then see if it comes back, if it comes back you have a minor leak. Re-torque your valve cover, it only takes a few minutes.
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #11 · (Edited)
Thank you guys so much!! I did clean it a little bit and looks like it didn't come back!!
So I will clean it more and keep pay attention to it !!
Thanks again
Happy New Year!!

And I am going to call Mitsubishi...Maybe it still under warranty...XD
 
1 - 11 of 11 Posts
Top