Mitsubishi Lancer Evolution Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2,671 Posts
Discussion Starter · #1 ·
Hey guys
As many of you know I just got my built engine in and I'm throwing this code. I read and clear the code and it goes away for about 100 miles. What do u guys think I should trouble shoot? I read some where it could be the cams not aligned properly (hope map did this correctly) , stretched timing chain, mitsu says
For
That code they've been replacing timing chain. Oil control
Valve. And a cam sprocket...taking it down there today's to see what's what. Please ANY info would
Help. Especially from engine Builders
Thanks!!


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
14,174 Posts
Fucking ay man.
 

·
Registered
Joined
·
9,566 Posts
I'd like some more information on this also I have the same code piping up in my new built engine. For those of u go have replaced the oil control valve which one did you guys replace?
It didnt fix the issue for Mazz. I would take it in. He's tried various control valves an solenoids with no success. Its now being traded in.
 

·
Registered
Joined
·
524 Posts
Damn same with mine. I'm so fed up with this damn problem. I just got back from the dealership and they replaced my control valves and said my timing chain was in spec. Code still popped up. I really will never own another mitsu. This has been going on for at least 6 months now. NO ONE KNOWS what this code is for. HAs anyone said they replaced the CAM SENSOR because it went bad? I'm about to say screw my warranty and replace it myself. Or just go to AMS and pay someone who knows more about the car they DID NOT BUILD. Mitsu ftl
Only thing my car has is an exhaust. That's it.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top