Mitsubishi Lancer Evolution Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
455 Posts
Discussion Starter #1
theres is a popping/squelching noise coming from the front of the car while in am doing turns at low speed. usually lock to lock while maneurvering out of a parking lot, or turning right at a stop sign.

it sounds like it is coming from the left front side of the car. but the front in general for sure. will try to get a vid inside and outside of the car tomorrow.

i have taken the transmission out and done a clutch swap on my own, that required removing the motor/trans mounts and such. could it be on is not properly tightened all the way? also, i recently went to lower offset wheels and changed the scrub radius and increased the effort on the pump (and im assuming the rack as well)

thanks for any help you guys can offer
 

·
Registered
Joined
·
8,771 Posts
Damn these warmer temperatures are spawning all kinds of noises this week!

I am in for the strut, ball joint, bearing, and/or doobie conversation!

:jpopcorn:
 

·
Evos before hoes
Joined
·
2,599 Posts
mine has done this for three years:( Mitsu said its just the body flexing
 

·
Registered
Joined
·
8,771 Posts
My front end also pops when turning into a raised parking lot.... It seems like it is just getting worse.
Hah, now that I have had since day one! Full stock to full suspension. Anytime I turn right going up or left going down. Some spots make a horrid sound, but typically just a pop.
 

·
Registered
Joined
·
538 Posts
Same here, backing out or turning into a tight parking spot, and all sorts of click/clack noises from the steering. I've only put 2,000 miles on the ODO.
 

·
Registered
Joined
·
455 Posts
Discussion Starter #7
damn. i was looking at some other new thread and they were talking about the factory struts/ball joints being pos's. i know when i re-assembled my strut the first time i didnt torque the camber bold correctly and it fell out sometime during a 200mile drive and i finished the drive without noticing too much. i was worried that i may have a strut about to go out
 

·
Registered
Joined
·
1,403 Posts
I had this same issue on another car. I would suspect your ball joints and tie rod ends! No harm getting them inspected.
 

·
Registered
Joined
·
455 Posts
Discussion Starter #11
18x9 +20 offset. and no, its not clipping because it did that at first, and now i have no more wheel well lmao. i'll take it to go get inspected this weekend
 

·
Registered
Joined
·
438 Posts
this has been discussed many times. Not sure anyone knows what it is but chalks it up to another rattle, clank, pop noise that the X is plauged with.
 

·
Registered
Joined
·
2,063 Posts
Had the same issue with my new X. Started after a month or so and it was driving me nuts. Took it to the dealer and they found nothing and said it was the awd system breaking in...problem eventually disappeared although since I had to get my tcase replaced I suspect that it could have been related since I can't remember if it fully went away before or after I got it fixed. Took my car into another dealer the other day for a wingless trunklid install and the service rep noticed my tcase had been fixed and said that she had seen several other 2010 evos come in with the same issue all with less than 10K mi (mine had about 7K when it went bad) and that it should be a recall...might be worth it to have your tcase checked out just in case. That's worst case scenario. Initially, the explanation that a close car savvy friend of mine, including one of the evo service reps gave me is that since my car was new that it was just breaking in and that since there is zero sound insulation in the evo for weight savings, noises that cars make are just audible in this car and are "normal" sounds that all cars make that normally go unheard in regularly insulated vehicles...
 

·
Registered
Joined
·
3 Posts
Mine just started popping front passenger side, and rear TODAY. I'm gonna see what the dealership says, then I'm taking to FFTEC (Hayward Cali) and seeing what they say. The car was pop free until 31500K. I beat the crap outta all my cars on the hills around SJC, and this is the first time I've had this experience. Damn Mitsu, Love the handling hate the noises. I've been reading the forums, it sounds like its the bearing at the top of the struts. If I can't figure it out, I'll buy a STI, Keeping this monster and tear it apart. But if I have multiple corners acting up, seems like everything is wearing out at the same time.
 
1 - 15 of 15 Posts
Top