Mitsubishi Lancer Evolution Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
360 Posts
Discussion Starter #1
For quite some time now my car had a very unstable idle even though i had all the reflashes. It wasnt until I became very frustrated did i discover on EvoM that someones fuel pressure regulator hose came off and caused this exact same problem.

He wasnt alone in this, because someone else had this problem. It was then I decided to see if this was also my problem...and you guessed it...it was. Thank you mitsubishi for yet another flaw to constantly keep checking.

It seems that the fuel pressure regulator hose has a very loose connection to the engine. It can be located next to the engine oil dipstick under the plastic spark plug cover. If it came off on your car a simple zip tie should do the trick. Here is a picture thanks to member SiC from the EvoM forum. He helped in discovering this problem. Credit goes to him as well as other members of that thread "What hose is this? --- it fixed my idle"

http://forums.evolutionm.net/evo-x-general/441410-what-hose-fixed-my-idle.html#post7463278
 

·
Registered
Joined
·
1,077 Posts
Nice, thanks for pointing that solution out. I haven't had idle problems since I started modifying the car. I guess my car was begging to be modded.
 

·
Registered
Joined
·
360 Posts
Discussion Starter #3
Nice, thanks for pointing that solution out. I haven't had idle problems since I started modifying the car. I guess my car was begging to be modded.
Yea no problem, im glad your car was holding up. This thread/problem on EvoM was kind of hidden and no one on the X forums mentioned it so i didnt want to have anyone out of the loop.

Heres an early morning bump for everyone! Check your hoses regularly! :thumbup:
 

·
Registered
Joined
·
437 Posts
Thanks man, its really hit or miss with the crazy idling. It happened to me this morning, where it would almost stall... Craziness. I'll try it out today. Can you think of any reason why it wouldn't do it all the time?
 

·
Registered
Joined
·
62 Posts
I hope you hadn't really been driving your car in boost at all with that hose off. When mine came off it caused a terrible lean condition cause the fpr didn't see pressure from the intake manifold.
 

·
Registered
Joined
·
3,470 Posts
my fuel pressure regulator hose came off. seems to be a regular occurrence. gotta get a hoseclamp. Furthermore, a rough idle is not the only problem introduced by that hose coming off. You may also see higher than normal AFRs and that's never good. I am glad I caught it early on my car before it blew itself to bits.
 

·
Registered
Joined
·
646 Posts
Damn, I should check mine. I don't think its off because my wideband indicates low 11's AFR during WOT pulls. I guess i'll find out soon enough.
 

·
Registered
Joined
·
1,440 Posts
ya know my fuel pressure regulator came off awhile back but my car didnt pop or n e thin....as a matter a fact it was faster lol....my air fuel ratios werent good but no popping or n e thing of that nature & my idle was smooth.
 

·
Registered
Joined
·
430 Posts
damn, i was driving for over a month with that idle.. got the p0171 code yesterday and then found this thread for the hose. idle fixed, lets hope motor holds. trade in soon anyway
 
1 - 15 of 15 Posts
Top