Mitsubishi Lancer Evolution Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Anyone had trouble starting their car today? Didn't seem that cold today... There was even more colder days and my car started with a few tug but comparing today won't even start after I waited to become more warm then started.
 

·
Registered
Joined
·
905 Posts
Anyone had trouble starting their car today? Didn't seem that cold today... There was even more colder days and my car started with a few tug but comparing today won't even start after I waited to become more warm then started.
Parked in garage or outside?
 

·
Registered
Joined
·
2,991 Posts
next time that happens get a long extension cable, a hair dryer and blow it on the air filter.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #4 ·
It was outside on the driveway. It sounded like completely dead lol. Should I bring it in to Mitsubishi? Will they charge me for it?
 

·
Registered
Joined
·
2,991 Posts
The Mitsi OEM panasonic Battery does not like the cold at all, it could be that?
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #6 ·
Yeah these days the battery sounded very weak seems like barly starting.
 

·
Registered
Joined
·
5,593 Posts
I dont notice any difference due to the cold. But if i havent driven my car for a few hours it takes abit longer to crank over ever since i installed my fuel pump.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #9 ·
Well brought it in to platinum guess will see what they say. Better not charge me for it...
 

·
Registered
Joined
·
2,991 Posts
Good luck and be sure to post up what they said dude!
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #11 ·
Looks like I got it replaced under warranty but they gave me the same looking battery... Heh... have a feeling it's going to fail
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top