Mitsubishi Lancer Evolution Forum banner
1 - 15 of 15 Posts

·
Banned
Joined
·
132 Posts
Discussion Starter · #1 ·
Hey guys Im having some problems!
I hooked up a grimmspeed EBCS then got tuned... for some reason, my car keeps wanting to stall.. Its a pain in the asS!
and Im getting engine codes
-Random Miss Fire
-Exhaust Camshaft Posistion Actuator Circut / Open (Bank 1)
-Turbo/Super Charger Wastegate Solenoid A

Also when I give it on the hwy I some times get a huge loud POP in my exhaust and my car doesnt have any power/slows down
 

·
Registered
Joined
·
701 Posts
where did you get tuned ?

I would start by calling them
 

·
[Rally Driving Madman]
Joined
·
2,500 Posts
Seems to me the title of thread is wrong.

Should be the case " problem with my tune or install with grimspeed ebc."

Go back to your tuner he is the one who should fix this, and has a chance to overlook the whole situation... just make sure you drive it carefully you dont need any premature damage in the engine.
 

·
Banned
Joined
·
132 Posts
Discussion Starter · #7 ·
could also check to make sure the lines are hooked up correctly on the ebcs. also check for anything else that may have popped off
the EBCS it hooked up as shown on grimmspeeds site :S
everything else is hooked up right

Seems to me the title of thread is wrong.

Should be the case " problem with my tune or install with grimspeed ebc."

Go back to your tuner he is the one who should fix this, and has a chance to overlook the whole situation... just make sure you drive it carefully you dont need any premature damage in the engine.
Cant lol, the tuner lives In NY and I live in Canada... 18hr drive
Im going to call him but hes not getting back to my emails or FB message fml
 

·
Registered
Joined
·
214 Posts
Seems to me the title of thread is wrong.

Should be the case " problem with my tune or install with grimspeed ebc."
One of my pet peeves is that whenever people ask for help on this forum, it's hardly ever titled appropriately. Usually I just see "Engine Problem" or "Help!"

:wtfsign:

How hard is it to give an idea about the thread in the title? :duh:

Anyway, in this case, to the OP: It's probably the tune that needs work. Since the tuner is 18 hours away, I'm assuming he e-mailed you a tune you loaded onto the car?
 

·
Banned
Joined
·
132 Posts
Discussion Starter · #9 ·
One of my pet peeves is that whenever people ask for help on this forum, it's hardly ever titled appropriately. Usually I just see "Engine Problem" or "Help!"

:wtfsign:

How hard is it to give an idea about the thread in the title? :duh:

Anyway, in this case, to the OP: It's probably the tune that needs work. Since the tuner is 18 hours away, I'm assuming he e-mailed you a tune you loaded onto the car?

It is in the title... the BCS connection ports were changed, the guy who tuned my car said when I did the motor swap I much have connected it wrong.... had a few codes and read up on the BCS and it was in the right way the first time,,, so I put it back how it was... a day later my car kept wanting to stall out.. so thats why I figured it had to be something with the BCS.. today I changed it back to how the tuner had it and nothing changed after the codes were deleted and an hr of driving so I changed it back again lol

No I was going to get tuned by Ivey but then they got backed up... so I was stuck in NY-NJ area and needed to get tuned.. so I called up Vinny Ten.. so was not e-tuned
 

·
Registered
Joined
·
214 Posts
SPÖÖLIN ↑↑;999613 said:
It is in the title... the BCS connection ports were changed, the guy who tuned my car said when I did the motor swap I much have connected it wrong.... had a few codes and read up on the BCS and it was in the right way the first time,,, so I put it back how it was... a day later my car kept wanting to stall out.. so thats why I figured it had to be something with the BCS.. today I changed it back to how the tuner had it and nothing changed after the codes were deleted and an hr of driving so I changed it back again lol

No I was going to get tuned by Ivey but then they got backed up... so I was stuck in NY-NJ area and needed to get tuned.. so I called up Vinny Ten.. so was not e-tuned
Oh you misunderstood me mi amigo. When I wrote about incorrect thread titles I didn't mean this thread. I was merely illustrating the grand majority of other help threads.
 

·
Registered
Joined
·
1,595 Posts
SPÖÖLIN ↑↑;998482 said:
Hey guys Im having some problems!
I hooked up a grimmspeed EBCS then got tuned... for some reason, my car keeps wanting to stall.. Its a pain in the asS!
and Im getting engine codes
-Random Miss Fire
-Exhaust Camshaft Posistion Actuator Circut / Open (Bank 1)
-Turbo/Super Charger Wastegate Solenoid A

Also when I give it on the hwy I some times get a huge loud POP in my exhaust and my car doesnt have any power/slows down
I think the last one means you just need to plug the harness for the passive/coarse solenoid back in to the stock boost control system. I don't remember which color it was but one needs to be connected to the EBCS, the other to the passive/coarse solenoid. I think on a 2008 evo you can disable this, haven't seen a disable for 2010+ yet.

Make sure the correct harness is plugged into the EBCS, it does matter which one is connect to it - I just don't remember which color is which off-hand.

Also make sure you have the EBCS connected right. It's a 3-Port so it should have 3 tubes connected to it. One goes to the WGA, one goes on that black tube that's bolted to the turbo where the UICP connects, and the last port its acceptable to either vent the port or route it to the nipple on your intake - if you do vent make sure to cap the nipple on the intake (if your intake has it).

You just gotta make sure you make all those connections to the right port on the EBCS. Maybe someone who owns that one can tell you which ones go where?
 

·
Banned
Joined
·
132 Posts
Discussion Starter · #13 ·
whoa... "motor swap"??? what are we talking about here?
lol yes, I went to the states to swap motors with another guy, he was sick of waiting for his car to be built so he went out and bought a 2011 GTR lol now he wants to mod that and sell his evo, even tho it only had 2k miles on it since the build,, So I got it from a 2008 and it was at a very good price.. Plus no down time, we swaped the motors in one day and I got tuned the next!

Oh you misunderstood me mi amigo. When I wrote about incorrect thread titles I didn't mean this thread. I was merely illustrating the grand majority of other help threads.
My bad man hahaha thanks :eek:

I think the last one means you just need to plug the harness for the passive/coarse solenoid back in to the stock boost control system. I don't remember which color it was but one needs to be connected to the EBCS, the other to the passive/coarse solenoid. I think on a 2008 evo you can disable this, haven't seen a disable for 2010+ yet.

Make sure the correct harness is plugged into the EBCS, it does matter which one is connect to it - I just don't remember which color is which off-hand.

Also make sure you have the EBCS connected right. It's a 3-Port so it should have 3 tubes connected to it. One goes to the WGA, one goes on that black tube that's bolted to the turbo where the UICP connects, and the last port its acceptable to either vent the port or route it to the nipple on your intake - if you do vent make sure to cap the nipple on the intake (if your intake has it).

You just gotta make sure you make all those connections to the right port on the EBCS. Maybe someone who owns that one can tell you which ones go where?
Thanks for the post buddy, this morning I went over all the lines and everything was good and in where should be!
as for that last code, what you said was correct, I switched it back to how I had it "how grimmspeed showed on their how to"
So that code I dont think has came back on :S

Calling My Tuner Right Now!!
 

·
Banned
Joined
·
132 Posts
Discussion Starter · #14 ·
Humm, Tuner said bring it down so they can have a look LOL 18hrs NO

He also said it could be due to the colder weather who knows... Im just going to data log it on Friday and see how that goes!
 
1 - 15 of 15 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top