Mitsubishi Lancer Evolution Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
So about 10k miles ago I upgraded the clutch to the exedy twin disk from a ACT 6 puck.

Everything was fine at first. Nice stiff clutch, shifted perfect. Never had a single issue of lockout/grinding/anything. The only thing I can think of is the fork was far to the left(farther away from slave) then what Jacks Transmission recommended in his videos, he said it should be about dead center. This is when it was first installed.

So it ran great for about 10k miles & that's when my issue seem to start. I noticed the transmission fork kept shifting closer to the slave cylinder. So I would adjust the clutch fork stop closer to the slave as it moved in. I read that you need to keep adjusting it for clutch wear.

It confused me because I don't abuse the clutch, never launched the car. I do shift at high rpms, but never had any drag or slip on the clutch.

So anyway as the fork kept moving farther inward eventually last week I felt my peddle get unusually soft. I instantly was like, that's not right. Normally it was very very stiff.

So I figured the clutch killed off the MAPerformance upgraded master cylinder. The fluid was unusually dark so I read thats the seals failing.

I took the car to the shop and dropped it off because it was making a really odd/terrible noise when trying to rev with the clutch in. My thought was the throw out bearing was touching the fingers on the clutch because of the failed CMC, so it was not traveling enough for full engagement/disengaging.

So I ordered the Magnus CMC & a new slave from Mitsubishi. I go to pick the car up today and the pedal feels way off.

Engagement is at the floor as soon as you move your foot. No freeplay at the top of the pedal. Does not feel as stiff as before. Does not sit as high as before(it is now equal with the break pedal it use to sit higher)

I do not want to drive the car like this & cause any damage because it's doesn't feel correct. Is there a difference in the MAP CMC & the Magnus? The look identical from the photos.

I tried going to Mitsubishi and those assholes charged me $200 to adjust the rod that goes in the CMC, did not bleed the system like I asked. They told me "it's a real pain in the butt". At this point I just drove home before I had a stroke my hands where shaking at this point.

Can anyone help me out here? Does that mean there is still air in the system or the pedal is improperly adjusted? I checked the fluid when I got home and parked and it was low so the shop said bring it back tomorrow but I am just stumped as to why the pedal feels so extremely different? I've never smelled the clutch at all, just that weird noise before I had the CMC/slave replaced.

P.S. I have tried to read and watch everything I can to fully understand how the system works. Am I missing something very simple?

PSS. Fluid level in the reservoir dropped after replacing CMC/Slave & driving the car home. Clutch engagement feels extremely odd.
 
1 - 2 of 2 Posts
Top