Mitsubishi Lancer Evolution Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
1,677 Posts
Discussion Starter · #1 ·
As some of you know already I am going to put together a list of everyone on here that has had this issue and send in a formal complaint letter to Mitsubishi Canada. I would really appreciate if you could fill out your info as it will help out if we have a number of people rather than just a few.

Click HERE for the list.

Thank you

-Josh
 

·
Registered
Joined
·
1,677 Posts
Discussion Starter · #3 ·
Has anyone actually contacted AMVIC and launched a formal complaint about this?
I did and they basically told me there is nothing they can do.
 

·
Registered
Joined
·
1,677 Posts
Discussion Starter · #5 ·
Only for Mitsubishi Canada? How bout US?
Not sure.

I was thinking about bringing it to the attention of Mitsu USA when I was living in Florida but never did.
 

·
Registered
Joined
·
190 Posts
I just got a C161f code... but only when the temp outside is 10+ C....

My car has 45k KM on it and 3 weeks out of warrentee.... I am hoping they help me out with this one
 

·
Registered
Joined
·
94 Posts
Mike1, I just had my acd pump replaced at 40K and 8 days past warranty . Be polite, explain the situation, get the salesman/manager involved and hopefully you can get it done. I have a good relationship with the dealer who communicated with head office so that helped. I own a ralliart but that should not matter. I only had to pay for install time since it was at a different dealership and they would not give me a goodwill install.
 

·
Registered
Joined
·
201 Posts
we're talking about the 3 yr warranty right? i'm already into the 4th year. i got the same code as mike, and my tarmac dash light flashes. dealer says nothing is wrong and that it's the awc switch on my steering wheel that needs replacing -_-

Mike1, I just had my acd pump replaced at 40K and 8 days past warranty . Be polite, explain the situation, get the salesman/manager involved and hopefully you can get it done. I have a good relationship with the dealer who communicated with head office so that helped. I own a ralliart but that should not matter. I only had to pay for install time since it was at a different dealership and they would not give me a goodwill install.
 

·
Registered
Joined
·
646 Posts
IM on my 3rd one :-/
 

·
Registered
Joined
·
6 Posts
Acd pump issues in canada

Hey Guys,


I just wanted to provide an issue I had with EVO X AYC/ACD PUMP MOTOR. In the beginning I received the traditional AWC light on dash. After checking I realized one of my Solenoids broke off the AYC/ACD Pump. I then proceeded with finding a replacement solenoid which then came by the issue of the pump not working altogether. After further looking into the issue I then realized the cost for replacement of the pump would be $2000 CAN that is as I live in Toronto Canada. I then realized that the motor on the pump shorted and proceeded with a used replacement. I then installed the pump and soon there after the motor shorted. I proceeded with this action 2x only to provide failure to the motors.

I then had enough of this and was thinking to replace the whole pump itself. I then came accross AYC/ACD Pump Refurbisher [email protected]. With my experiences and his knowledge we found out the cause to the motor short was due to the AWC ECU firmware. I then proceeded to Mitsu dealer and asked then to check AWC ECU. They mentioned the firmware was out of date and they proceeded to flash to the latest and greatest.

I then proceeded with purchasing a newly refurbished pump from [email protected]. This pump is amazing, upgraded gasgets, seals and anti-corrosion chemical to stop the dreaded rusting. I then proceeded with the install at my local mechanic PROTOTECH (Ask for Mike) and used a trusty SNAPON computer to bleed/execute the pump accordingly. There is definatley no need from dealer to bleed this correctly.

I'm glad to say that I have been operational for 3+ months now and would deal with [email protected] again. Very knowledgable/helpful individual and would do this again with him.

If anyone has continual problems please don't hesitate to ask questions as I have filled numerous complaints to Mitsubishi about this with no replies. Simply a very bad design and location to put this but c'est la vie.
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top