Mitsubishi Lancer Evolution Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
Just put the car together. 2014 gsr and we keep
Getting BRAKE SYSTEM SERVICE REQUIRED.. we have double checked everything and no idea why it’s on. Evo scan shows no code, pads are new, it has plenty of fluid. Anyone got any tips lol
 

·
Registered
Joined
·
219 Posts
Am at the same boat, replaced my pads and the abs system service required started to pop.
everytime i move the car it pops.
I scanned it and i got this error C2104

i think its related to wheel sensors or something.
 

·
Super Moderator
Joined
·
578 Posts
I was going to say that the brake fluid was low, since you can get that message from the fluid sloshing around at boost.

Maybe the fluid level sensor is going bad? Because I think that will trip the light on the dash, but doesn't show a code as far as I know.
 

·
Registered
Joined
·
1,015 Posts
Check the fluid level sensor. Unplug the sensor and see if there is any change to the dash. If I recall, the sensor triggers the light when the sensor closes the circuit.

If it works in the opposite manner, then use a short lead to jumper the plug. If the light goes out, then the sensor is the issue. I'd have to reference the FSM to see if its looking for an open or closed loop
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #6 ·
Check the fluid level sensor. Unplug the sensor and see if there is any change to the dash. If I recall, the sensor triggers the light when the sensor closes the circuit.

If it works in the opposite manner, then use a short lead to jumper the plug. If the light goes out, then the sensor is the issue. I'd have to reference the FSM to see if its looking for an open or closed loop
So we actually tried that. The sensor is either closed or open circuit. We jumped it and nothing changed.
 
1 - 9 of 9 Posts
Top