Mitsubishi Lancer Evolution Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Greetings!

I have a possible stupid question here but I'm stuck because I cannot figure out what the Service Required image means exactly. I looked in the owners manual and even called two dealerships and still no luck. Does anyone know what this means and is it a serious issue? Thanks!
 

Attachments

·
Registered
Joined
·
678 Posts
Pull the negative cable off the battery. Put it back on and start the car. Hopefully it should be cleared. If it comes back take it to the dealership and have it diagnosed.

Greetings!

I have a possible stupid question here but I'm stuck because I cannot figure out what the Service Required image means exactly. I looked in the owners manual and even called two dealerships and still no luck. Does anyone know what this means and is it a serious issue? Thanks!
 

·
Registered
Joined
·
5,820 Posts
Doesn't that mean there may be an issue with the ACD/AYC or something along those lines? I'd read the code before driving it. Just clearing it by pulling the cable off the battery doesn't fix anything, and often codes don't come up immediately, they take time before they reappear. Yes, if it comes back, then it needs to be investigated, but if there is an issue, clearing the code and driving it can make things worse, and it's NOT cheap to fix these types of issues.
 

·
Registered
Joined
·
353 Posts
Could just be a broken steering angle sensor. Happened to me one day. Take it to the dealer and have them read the code.
 

·
Registered
Joined
·
6,110 Posts
Could just be a broken steering angle sensor. Happened to me one day. Take it to the dealer and have them read the code.
This.


I had the same issue. SAS goes bad and that dumbass warning comes on. It'll also set if the toe is sufficiently off.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #11
dang it...yeah it's modded of course. guess I'll have to suck it up and pay the $98 just for them to look at it....plus what ever the additional charges are. anywhere else i could go/do?
 

·
Registered
Joined
·
6,793 Posts
when i had this error it was my acd pump. Hopefully yours will be the less expensive steering sensor or alignment issue.
 

·
Registered
Joined
·
6,793 Posts
The pump should be warranty, shouldn't it?
if he is stock it should be covered if he is still within warranty. Mine was under warranty since mitsu had replaced it after i got rear ended and it went bad within 4 weeks of getting it back.:duh:
 

·
Registered
Joined
·
2,008 Posts
I have had that light twice, first it was the angle sensor and the other was that my chamber on my alingment was off. Don't have warranty; sensor cost me around $170 and $130 for labor.
 
1 - 20 of 35 Posts
Top