Mitsubishi Lancer Evolution Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
1,531 Posts
Discussion Starter #1

·
Registered
Joined
·
8,577 Posts
I can't remember I want to say 180/210 and I remember thinking I wish it was 150/180, once it gets above 180 things get hard to cool, I can maintain it but I can't cool it so the fans never shut off. That being said you don't want the fluid too cold either, it's a fine line. I opted to keep mine and try it a bit more, but I might try to find a lower one in the future.

But the point of this is that it does work.
 

·
Registered
Joined
·
1,531 Posts
Discussion Starter #5
I can't remember I want to say 180/210 and I remember thinking I wish it was 150/180, once it gets above 180 things get hard to cool, I can maintain it but I can't cool it so the fans never shut off. That being said you don't want the fluid too cold either, it's a fine line. I opted to keep mine and try it a bit more, but I might try to find a lower one in the future.

But the point of this is that it does work.
You don't happen to remember the part number you used?

I already have a heated sump, CBRD radiator and an AMS cooler, so getting the fluid to temp isn't a problem.
 

·
Registered
Joined
·
8,577 Posts
Found it!!

it's a Moroso 63760, 160 on 140 off, it comes with a switch but I through that part away ;). I have a bypass switch incase I want to force it on anyhow. Or at the very least that was the one I was looking at, I'm not sure why I thought 180 on, maybe I switched last minute. But I'm pretty sure it's the one I bought, I know the one I have is 1/8" NPT, I'm having a hard time verifying if this one is that.
 

·
Registered
Joined
·
1,531 Posts
Discussion Starter #11 (Edited)
Found it!!

it's a Moroso 63760, 160 on 140 off, it comes with a switch but I through that part away ;). I have a bypass switch incase I want to force it on anyhow. Or at the very least that was the one I was looking at, I'm not sure why I thought 180 on, maybe I switched last minute. But I'm pretty sure it's the one I bought, I know the one I have is 1/8" NPT, I'm having a hard time verifying if this one is that.
Wow, yours comes on super early.....no overcooling concerns?

I saw your third pic, which port did you thread the switch into?
 

·
Registered
Joined
·
8,577 Posts
the top hole in the third pic is the thermostatic switch, the one below that is my nexus temp gauge sending unit, it didn't come with the hole I threaded it. I still feel like mine is a 180/190, I think that is the one I want to switch to. The problem I have is once I'm at 180 it's too late I can't cool it. So I wanted to go on around 160 to give it time to start cooling. But I think I opted for higher cause that 140 off seemed a bit low.
 

·
Registered
Joined
·
1,531 Posts
Discussion Starter #13
Hmm....if I use a SW536 which is M16 x 1.5, I'd have to tap a new thread?

Is there any existing that I could use? I assume you have a Dodson.
 

·
Registered
Joined
·
1 Posts
Hey, i hope that i'm in the right place. I had my car modified recently but today i'm facing a problem with it, it gets really hot. Idk if that’s related cause the mechanic mentioned that he switched the SSP Cooler temperature-sensitive instead of switched. I called him and he asked me to check the transmission fluid and sent me this video about how to check transmission fluid ( he knows that I'm noob mechanically with cars lol!) so i followed the video and everything looks good but the car’s still hot. Idk what to do i'm in another state away from the mechanic so help !!
 
1 - 15 of 15 Posts
Top