Mitsubishi Lancer Evolution Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,125 Posts
Discussion Starter #1
This only seems to happen or i can only smell it for a little while after i fill it. I found where it is leaking but cant figure out if it is just a bad clamp and leaking around the hose or if the nipple and mount point itself is leaking. Anyone have a problem with this at all? I do have a 255 installed too incase it matter
 

Attachments

·
Registered
Joined
·
155 Posts
Visually inspect the hose and nipple for cracks, it's possible one or the other was damaged during the installation. If you don't find anything, try tightening up the clamp by pinching it together while its removed and reinstalling.
 

·
Registered
Joined
·
1 Posts
Gas leaking

Just happened on my 2011 Evo MR this weekend. Topped off the tank, parked it in the garage and an hour later the gas smell made it's way into the house. Not leaking but definitely gas seeping down the drivers side of the tank. Headed to dealer on Friday, I'll post what they find.
 

·
Registered
Joined
·
339 Posts
Do not over fill these cars a lot of times the pump won't shut off right away either and you will get spray with gas. Only ever have this happen on my Evolutions
 

·
Registered
Joined
·
1 Posts
Gas leaking

Just happened on my 2011 Evo MR this weekend. Topped off the tank, parked it in the garage and an hour later the gas smell made it's way into the house. Not leaking but definitely gas seeping down the drivers side of the tank. Headed to dealer on Friday, I'll post what they find.
So what did they find?
 
1 - 6 of 6 Posts
Top